MIDI input not working

I must be missing something, but I can't figure out what exactly. Here's what I've got going on.


I am using a launchpad pro (not the new MK3) hooked up VIA USB directly to a Roadhog 4 with 3.13.1 (b2885) on it.

The launchpad is set up into drum mode, channel 1, MIDI out: ON

In the hogs MIDI configuration page: (device 1) > Device ID: 1, Device Group ID 112, MSC in/out (off), MIDI notes in/out (on)

MIDI note input: (MIDI channel 1) > Comment Macros
I've set every midi note to "GL1" which is just a simple intensity cue to test

And I get nothing... What am I missing here?
As a side note, I've hooked the launchpad up to bomes and confirmed the drum mode is sending out the correct CC notes. I must be missing a check box or something I'm guessing.

Comments

  • datadriverdatadriver Registered User, HES Staff
    Have you used Hog's built in MIDI viewer to troubleshoot?
  • ElusidElusid Registered User
    How do I open it? I was poking around for one and didn't find it.
  • maeganw12maeganw12 Registered User, HES Alumni
    [Setup] → (Midi Viewer)

    See what is recorded when you press a button on the drum pad
  • ElusidElusid Registered User
    Ah! Was looking for it in [Open].

    Alright, well the drum pad works great. Midi viewer sees it fine. Launchpad pro, nothin. I have tried a few different modes, made sure it's actually set to output midi. Zip. The weird thing is it, I hook it up to my PC and it spits out MIDI into Bomes fine.

    I've also tried using the actual MIDI plugs out on the Launchpad pro and use a MIDI to USB device back into the hog. Same result.
  • maeganw12maeganw12 Registered User, HES Alumni
    I'm not familiar with the Launchpad Pro, but it should work if it doesn't require a driver.

    Do you have Hog 4 PC on the computer? If so, can you try seeing if it recognizes the MIDI coming into Hog 4 PC?

Sign In or Register to comment.