Roadhog crashed during transferring showfiles

mvdmeulenmvdmeulen Registered User
Hello Community
I have just finished a theatrical tour which used an roadhog4 running software version 3.6.0, so far so good
At the last show I decided to copy all of the existing showfiles on the console to a usb drive, about 85 showfiles and 85 backup files. I did this with the file browser in the shell (so before you load a show file) It started to copy them but once at about 68% the desk completely freezed, and I wasn't able to do anything on it. Even Pig+Open+Backspace didn't do anything, the only solution I had was to pull the plug and restart the console. When rebooted i still had problems with the console. The response of the console felt laggy and the GUI was very slow: when pressing go the list on screen was moving a whole second later. Command keys were also delayed for some reason and it was very hard to run the show. I desided to reboot in the break which fixes the laggy feeling of the console but I would like to know what I can do to prevent such nasty behavior in the future.

After the last show i did't a full install of version 3.8.0 in the shop which seems to fixed all the issues. The console isn't feeling as slow as it was during the last show of the tour but now every once in a while, while making changes to the patch/using the fixture builder my internal dp stops responding and need to be restarted, any ideas on how to fix this?

Thanks in advance

Comments

  • ejberendsenejberendsen Registered User, Hog Beta
    Why did you not only copy the backup files? The show files it self are really big.
  • mvdmeulenmvdmeulen Registered User
    Because the backups were made at the start of the day, and the showfiles were saved at the moment I shut down the console that day, so I wanted to keep a backup of the start of the day and from the end of the day, but forgot to make a backup of the shows. I didn't want to re-open 85 shows to pull a backup. But besides that, I don't think its normal that a console crashes when it needs to copy just over 5 gb of data to a usb drive
  • MLorenzMLorenz Registered User, Hog Beta
    I always end the day with a backup and the next day I start from that backup and rename the file... So you can be sure that you always have an actual version, even when your showfile gets corrupted. And also during the day sometimes. I agree that on RH4 due to the missing backup button it takes a bit longer.
  • datadriverdatadriver Registered User, HES Staff
    "any ideas on how to fix this?"

    Yep. Don't back up that many shows at once. The archiving software in use is a 3rd party thing we did not write. It leaks memory, which is why your console feels laggy and/or completely locks up. We have replaced the 3rd party software with something that fixes the issue and is also noticeably faster for a future release. You must reboot to recover from the slow/laggy issue until this fix is released.
  • datadriverdatadriver Registered User, HES Staff
    This is fixed in our upcoming 3.9 release.
  • mvdmeulenmvdmeulen Registered User
    Hello Datadriver,
    Thanks for your reply, I did't reboot the console, unfortunately the laggy issue continued for a week, than I reinstalled the software which fixed the problems, it seems like in some way the showfile got slow in some way, any ideas?
    Thanks!
  • datadriverdatadriver Registered User, HES Staff
    What we changed really only affects the archiving/unarchiving of a lot of data. You only use that functionality when creating backups/loading backups, or loading a new fixture library.
Sign In or Register to comment.