Pretty major network bug in HogPC

jifopjifop Registered User
Hey chaps, upgraded to 3.3.0 and I've come across what I think is a pretty major problem.

Unless I'm being a massive idiot and missing something HogPC won't let me configure or use any network interface that isn't active (i.e plugged in and negotiated) and defaults the console to a local loopback address.

this is a pretty shocking problem as even once an ethernet cable is plugged in it won't recognise it so you need to exit HogPC and go back in for it to work.

I've tested this on three PCs now and they are all the same, previously this did not happen.


  • jifopjifop Registered User
    Unless I'm just being a massive idiot and missing something.
  • MLorenzMLorenz Registered User, Hog Beta
    What happens if you configure your settings in windows?
  • ShrunkenNedShrunkenNed Registered User, Hog Beta
    I was seeing this on a Surface 3. It defaulted to a loopback adapter only (greyed out, couldn't change it).
    Briefly played with the Windows network settings, and confirmed I was on the wifi network.
    Tried to do a wired network, but my apple ethernet adapter wouldn't work on the surface (shocked).
  • jifopjifop Registered User
    Both Nics are configured in windows correctly but unless the connections are active when hogpc starts they are unavailable to hog4pc and all interfaces are greyed out.

    HES seem to think this is the correct behavior however it causes some real problems in the real world, for example HogPC can no longer be used as a backup console using artnet.

    Assuming you have two NICs the artnet NIC will not become active until it is switched to therefore HogPC cannot use that NIC without being exited and restarted, obviously you could add another netwrk switch but again you are adding a level of complexity which was previously not there.

  • GordoGordo Registered User, Hog Beta
    @ ShrunkenNed
    My apple USB-Ethernet adapter stopped working with Windows 10 (surface Pro3 at the time), I found some drivers that let me see the adapter but would give me any output. In the end I got a Microsoft USB-Ethernet adapter which has worked flawlessly
  • MLorenzMLorenz Registered User, Hog Beta
    Ok I see your problem with the Artnet-Backup. I know that there had been some issues with network adaptors not being recognized correct and so, thats why this had been changed.
    For you scenario I would recommend that you get a managable switch and and configure it with spanning tree, so you also create an auto-backup scenario for your artnet.
  • jifopjifop Registered User
    Hi, I've been testing this and it really doesn't work well.

    I've got Cisco switches with spanning tree and with both sources plugged in my nodes just flick between the two sources. Is there an official line from high-end on the best STP settings? It's ridiculous really as it used to work so well before.

    I have found a workaround if you want to use a manual failoverover switches, start hogpc with the fixturenet nic connected to a switch then unplug it then it can be put through a manual changeover switch however the moment you unplug and replug a NIC, H4PC looses the ability to modify it as its no longer shown with the correct IP address. Stupid really as it means any network issues cause h4pc to loose this ability.
  • skierskier Registered User
    I had the same thing a month or two ago. I couldn't make it work and gave up.

    It never used to be this way, something has changed and not for the better.
  • jifopjifop Registered User
    Agreed, by fixing visualiser connectivity theyve screwed backup

Sign In or Register to comment.