[Bug] Position Merge Output Feedback

Buzz313thBuzz313th Registered User
FB4 Build b352

1. Start new show

2. Patch 10 Clay Pacy Alpha Spot 1200 Vectors (Haven't tried a different fixture as this is the one I found the bug with)

3. Sellect all 10 fixtures

4. With Encoder wheels set pan and tilt to 0 degrees, position time should snap to 100

5. Record a position pallete as "Home"

6. With Encoders Set Pan with and tilt to 45 degrees and record a position palette as "45/45"

7. With Encoders Set Pan and tilt to 90 degrees and record position palette as "90/90"

8. Clear Programmer

9. Sellect Fix 1-10, choose "home" position pallete and record to 1/1

10. Bring up output for reference choose show palettes in output and play 1/1.. Output should show Pos Palette "Home" in position and time columns

11. select fix 1-10 and apply "90/90" pos palette... Now look at output, it will show a correct reference to pos palette as "90/90"... Now merge or update to 1/1 and clear programmer. After the clear the output will show the old palette of "Home" in pan and tilt and "90/90" in time. It should show "90/90" across the board. Now deselect "show palettes" in the output display and you will see that raw output is correct and that only the UI reference to the palette is incorrect... but, since the palette reference is incorrect, the functions to mask with the "Live" key give inconsistent results since palette associations are wrong... Now wait... Now reselect "show palettes" in the output display and assert master 1 trying to refresh the cue. Nothing changes... Now, instead of an assert, just play cue 1/1 again and the palette reference will correct itself showing "90/90" across the board.

I remember in an early build seeing something like this, where the console had palette references messed up, but HES fixed it in a later build. Now I believe it's back again.



  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited April 2013

    Thanks for the information and great repro!
    I was able to recreate this right away and have logged bug D-01288 for this.
  • Buzz313thBuzz313th Registered User
    edited April 2013
    Sweet, thanks Michael,

    FYI, the missed association doesn't seem to be limited to the position palettes... The same thing happens with other directory items as well if you follow the same procedure.

    Any chance you can comment on this post, which I'm not sure if it's a bug or just a function not implemented..


  • dslodkidslodki Registered User
    edited April 2014
    Seeing something similar still happening with merge....been meaning to search the forums. Cue 1 running...Select heads, change values, merge to Cue 1. Clear programmer. New values not outputting. Assert Cue 1 and then it finally changes. Have noticed this failure to merge on v.3.1.9 in HogPC3 (discovered this the very hard way..."WHY do those lights keep going off!"...etc.) and still yet on 2.1.2 on RH4.
Sign In or Register to comment.