Help needed!! OSC remote

price4192price4192 Registered User
Could someone please post a tutorial or instructions (FULL INSTRUCTIONS!!!) on how to get the Hog template into the OSC iPhone app?!?!
I know the template is available for download on the HES website, but it is only a zip file...and it can't be opened from my phone.
I also understand that I need to point my app to the template, but I have no idea how.
Can't believe there aren't instructions yet (for someone who ISN'T a computer genius).
Any help would be appreciated!! Cheers!

Comments

  • price4192price4192 Registered User
    edited February 2013
    I should also mention...
    iPhone 4
    Nano Hog 4
    Sony Vaio all in one (windows 7)
  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited February 2013
    For details on how to load touch OSC templates onto your IOS device please read the instructions provided by the Touch OSC developer: http://hexler.net/software/touchosc
  • MLorenzMLorenz Registered User, Hog Beta
    edited February 2013
    * Load the template to your computer and unzip
    * Install TouchOSC on your iphone/ipad
    * Connect your iphone/ipad to your computer
    * Start itunes
    * Locate TouchOSC in the Apps tab of your iphone/ipad (in the lower part of the Apps tab you will find a list with Apps which are suitable for data-exchange)
    * select "add" and choose the template which you just had unzipped
    * Sync your iphone/ipad
    * Start TouchOSC and select the Template....

    There your go... Then only you need to set your ip-settings and ports, connect a wifi-system to the hognet and have fun....
  • price4192price4192 Registered User
    edited February 2013
    MLorenz wrote: »
    * Load the template to your computer and unzip
    * Install TouchOSC on your iphone/ipad
    * Connect your iphone/ipad to your computer
    * Start itunes
    * Locate TouchOSC in the Apps tab of your iphone/ipad (in the lower part of the Apps tab you will find a list with Apps which are suitable for data-exchange)
    * select "add" and choose the template which you just had unzipped
    * Sync your iphone/ipad
    * Start TouchOSC and select the Template....

    There your go... Then only you need to set your ip-settings and ports, connect a wifi-system to the hognet and have fun....

    Thanks so much!! Exactly what I needed. Cheers!!
  • Hans BHans B Registered User
    edited June 2013
    Hi,

    I'm trying to connect my iPhone with the OSC App to my Roadhog4.
    Checked all the steps as written above but still not working

    i'm not sure about the wifi part:
    - Is it okay to use an Apple Airport Express for the wifi communication?
    - No special configuration needed for this device?

    i followed the instructions in the manual: "20.2 Configuring OSC Input"

    - do i have also have to enable something els in the desk?
  • price4192price4192 Registered User
    edited June 2013
    Not sure if apple airport the issue (not familiar), but are you able to locate the console in the app? Make sure the port numbers are correct and try swapping IP addresses on the device and/or the console. I've found that I often switch the in/out ip addresses by mistake a lot.
  • datadriverdatadriver Registered User, HES Staff
    edited June 2013
    Hans B wrote: »
    Hi,

    I'm trying to connect my iPhone with the OSC App to my Roadhog4.
    Checked all the steps as written above but still not working

    i'm not sure about the wifi part:
    - Is it okay to use an Apple Airport Express for the wifi communication?
    - No special configuration needed for this device?

    i followed the instructions in the manual: "20.2 Configuring OSC Input"

    - do i have also have to enable something els in the desk?

    1) Yes
    2) No
    3) Yes - you must enable OSC output and input on your RH4.

    Double check that your iPhone has connected via WIFI to your airport (Settings->WIFI...confirm checkmark is present)
  • MLorenzMLorenz Registered User, Hog Beta
    edited June 2013
    You also need to configure your airport to the correct IP-range

    I also use this setup.
    To make life a bit easier turn on DHCP Server in the console and set the Airport to bridge mode.
    Or do a manual configuration of the IP-adress for your Airport, also turn then off the DHCP server in the console and Airport. Configure your iphone IP also manually
  • Hans BHans B Registered User
    edited June 2013
    Thanks Chris and Marc,

    Airport Express: Bridge mode
    Console: Enable DHCP server

    Now it works great!
  • ZachithZachith Registered User
    edited June 2013
    I am still truly at a loss, I must be missing something. I am on Nano Hog4 with iPad and touch OSC. On the iPad the Host matches what I'm being told by Hog next to the Port in the Input section, the Port #'s match on both and OSC In is enabled. The template is working fine on the Pad and I can see the green light working when I push buttons but nothing happens on the Hog. What am I screwing up???
  • price4192price4192 Registered User
    edited June 2013
    Are you seeing anything come up in the command line on the console when you press buttons on the iPad? (Trying to figure out what you mean by "I can see the green light working when I push buttons but nothing happens on the Hog")

    Which green light are you referring to?
    Also...what exactly are you trying to do?

    The easiest way to test is a simple: fixture # @ Full
  • ZachithZachith Registered User
    edited June 2013
    I think I found someone else with the same issue in another post. Apparently the IP addresses aren't matching up properly. The Hog gives a preface of 127.... while OSC is giving 192.....that was someone else's problem but I have no idea how to remedy that. I guess the green light means nothing, just the feedback on touch osc.
  • price4192price4192 Registered User
    edited June 2013
    You should be able to manually change the address for OSC in the console and manually change the address for the console in OSC.
    Setting up the first time sucks, best of luck to you!
  • ZachithZachith Registered User
    edited June 2013
    Here's a photo, I'm not sure what's wrong.
  • price4192price4192 Registered User
    edited June 2013
    I'm guessing its the IP address with the 127 that screwing it up.
    As a possible quick fix...change the 7002 port to 8001.

    Not sure how to correct the IP prefix, I am FAR from a expert on wireless connections.
  • price4192price4192 Registered User
    edited June 2013
    Don't have my console in front of me...
    What are the other options in the protocol drop down menu? Perhaps that needs to be changed?
    I will check my settings tomorrow and get back to you with (hopefully) some info that might help
  • ZachithZachith Registered User
    edited June 2013
    I really appreciate the help. TCP/SLIP and TCP/HDR, other post said UDP was the one needed.
  • ShrunkenNedShrunkenNed Registered User, Hog Beta
    edited June 2013
    just change your console address to the 192.168.1.n network. If the router broadcast DHCP, you can set the console to receive it's address via DHCP (network settings), and then you'll know which address is open.
  • ZachithZachith Registered User
    edited June 2013
    When I go to my router, it recognizes my computer with Hog 4 on it. The network is 192.168.1.100-150. I have assigned the computer to .149, which the computer verifies when I go to IP Config to get the address. I found the DHCP option under both FixtureNet and HogNet but not in Network Settings. I tried to have it detect the address under both of those places to no avail. Should it be different from the computer? If so, how can I get the other machines to detect it? If it should be the same, why isn't it?
  • MLorenzMLorenz Registered User, Hog Beta
    edited June 2013
    In your case when your router is working as a DHCP server you need to set you HOGPC network adapter to accept DHCP (SETUP-Control Panel-HOGNET)
    You will see the IP Adress also there.
    This IP Adress needs to be entered in the Touch OSC App in the HOST field
    Outgoing port of the ipad must be the incoming of the HOGPC and vice versa.
    In HOG PC you need also to enter the IP Adress of your Ipad into the Output field of the OSC configuration

    Protocol set to UDP

    But remember with HOGPC faders and encoders are dissabled!!!
  • GianGian Registered User
    edited July 2013
    MLorenz wrote: »
    But remember with HOGPC faders and encoders are dissabled!!!

    Why ???

    I just tried today, all works fine, except the Faders ( that is OK ) and the Encoders on the Hog 4 PC.

    Faders, not bother me much, but no encoders, that makes the remote pretty useless. Any work arround on this ?

    Regards

    Gian Bortolotti
  • Marty PostmaMarty Postma Registered User
    edited July 2013
    Gian wrote: »
    Faders, not bother me much, but no encoders, that makes the remote pretty useless. Any work arround on this ?

    OSC will only control ACTUAL hardware attached to the H4PC system.
    So if you connect a Playback wing you will have fader control, and if you connect a Programming wing you will have encoder control.....with a Nano wing you get both.

    Hope this helps. :)
  • datadriverdatadriver Registered User, HES Staff
    edited July 2013
    OSC will only control ACTUAL hardware attached to the H4PC system.
    So if you connect a Playback wing you will have fader control, and if you connect a Programming wing you will have encoder control.....with a Nano wing you get both.

    Hope this helps. :)

    No - if the console is a H4PC then encoders and fader controls via OSC is disabled. It doesn't matter what hardware is attached to the PC. It's a no-go.
  • datadriverdatadriver Registered User, HES Staff
    edited July 2013
    Gian wrote: »
    Why ???

    I just tried today, all works fine, except the Faders ( that is OK ) and the Encoders on the Hog 4 PC.

    Faders, not bother me much, but no encoders, that makes the remote pretty useless. Any work arround on this ?

    Regards

    Gian Bortolotti

    These features are disabled on PC by design. They are enabled on the console(RH4,FB4,H4). If you bring up the log viewer you will see warnings.
  • MLorenzMLorenz Registered User, Hog Beta
    edited July 2013
    OSC will only control ACTUAL hardware attached to the H4PC system.
    So if you connect a Playback wing you will have fader control, and if you connect a Programming wing you will have encoder control.....with a Nano wing you get both.

    Hope this helps. :)

    Marty, this is logged request, but not implemented!
    Hog4PC has no control of faders and encoders via OSC
    It is mentioned also in the manual and brochure i think
  • Marty PostmaMarty Postma Registered User
    edited July 2013
    MLorenz wrote: »
    Marty, this is logged request, but not implemented!
    Hog4PC has no control of faders and encoders via OSC
    It is mentioned also in the manual and brochure i think

    I stand corrected.
    I had thought this was implemented already for some reason.
Sign In or Register to comment.