Possible bug with Mac Aura profile?

ttrofatterttrofatter Registered User
Think I have been running into a bug lately when merging in the Mac Aura profile on a Road hog/ RHFB, and the other guys here at the shop agree that something isnt right.

Lets say I have a show file with 12 Mac 700s patched into my RHFB and nothing else. Fixtures respond the way they should to all commands. Open the shutter, throw in cyan (or any color at full), add in a gobo, pan left, tilt up. Now, when I hit clear, it clears EVERYTHING from the fixtures. next time I select them and hit Full:Enter, they open in white with no color or beam information.

Now, if I take that exact same show, and merge in the Mac Aura profile that I downloaded the library forum, patch 12 Auras (with or without FX, doesnt matter) everything gets a little strange. The Aura profile works fine when controlling the aura and the fx. If I grab my 700s (or any other MAC series fixture; 250, 700, 2k etc), turn them on at full, pan left, tilt down, add a color, and drop in a gobo and then hit CLEAR the Shutter will close and the fixture will return to its home position. However, when I turn them back on at full, the color and beam information is still there! It continues to hold the color and beam information until (.)BEAM and (.)COLOR are pressed.

This has happened to myself and several of our other programmers over the past months every time we have merged in the Aura Profile (either first or after the rest of the patch) We have checked defaults, tried it on our desks and desks from Mainlight.

Is anyone else out there experiencing the same problems? We have found a way to temporarily program around it, but with severall added keystrokes.

Could this be a glitch in the profiles? Or perhaps a bug in the software version? All our RH and RHFBs are running the current software release.




  • MitchMitch Registered User, HES Alumni
    edited July 2012
    Hello, one thing to try is looking in the Edit Fixtures window and see if the DEFAULTS for the color and gobo wheel may be set to something other than White or Open. Changing these should get you back. Occasionally these will get changed during a Merge.
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited July 2012

    What version of software are you running?
    We did have a bug in 3.2.3 that would change the default slot value from open to cto2800 (or something like that).
    You can check in the fixtures windows if this is the problem you are running into.

    edit fixtures
    Hit the sort by function button
    Hit the gobo button
    Is the default vaule 'open' or something else?
    If it is something else (cto 2800) then just change it back to open on ALL slots (color, gobo, prism ect.)
  • ttrofatterttrofatter Registered User
    edited July 2012
    Hi Mitch and Michael,

    I had gone through all the defaults and made sure that they were all set to open/ white. They were, I changed them all to something else, then changed them back. Same Issue.

    Desks were/ are running 3.2.3, we have not yet moved all our desks to 3.2.4
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited July 2012
    Did you check every slot default for every fixture in the show?
    The problem you are seeing sounds just like a default is not set correctly especially since you say it only occurs after the merge.
  • ttrofatterttrofatter Registered User
    edited July 2012
    The first show I noticed the problem on I had 6 Mac2ks, 12 Auras, 4 Mac250s, 2 QFX150s and a bunch of RGB LEDs. I Also had a LOT of time in standby and I did go through every slot of every fixture and everything was open/ white. The thing is, it wasnt like it was clearing to the same gobo or color every time, it was sticking with whatever the last information was. It wouldn't retain the prism, rotation, or focus information, just whatever the actual gobo/color was.

    Since then, it has become a regular occurrence and I have just started recording a palette with IPCB and selecting that prior to any new programming.

    Do you suspect that 3.2.4 this will solve the problem?
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited July 2012
    Does this always occur after the merge?
    The only time we have heard of this is when a slot is not at it's default value.
    Did you by any chance make a parameter none releasable?

    Note sure what you are running into so I can not say it the problem will be present in 3.2.4.
    If you can install 3.2.4 on a personal computer, run your patch-merge repro and see if you run into the same problem.
  • ttrofatterttrofatter Registered User
    edited July 2012
    No, it does not always happen... I almost wish it would so I could narrow down exactly what I'm running into. I would say that it tends to happen more when I am running several universes (last time I ran into it I was running 14 universes across several DP8000s)

    I'll get back to you after I get a chance to update the consoles
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited July 2012
    So it does not always happen after a merge BUT you only see this problem after a merge has been performed?

    If you have a copy of a good and bad show please send them to me and I will take a look. Also send the Aura library you are using.
Sign In or Register to comment.