Can't install 2.5, dagnabit.

steelcondosteelcondo Registered User
I am running sp3 and can not update to 2.5. I removed the previous version of Hog 3 PC using the MS uninstall tool, as described in the technote. When I try to install 2.5 it goes through all the motions until the end of the process when it says it is "rolling back action" and then does not "alter my system."

I tried taking my system back to sp2, reinstalling and then uninstalling hog 3 pc (version 2.4). And then reinstalling sp3. And then reinstalling hog 3 pc 2.5 with the same bitter results. What a huge waste of time.

At the moment the only versions of hog 3 pc I can run on this machine are very old and from the disks I got with my system.....version 1.4.

Can anyone think of something else to try, short of reinstalling windows altogether ?

thanks for your thoughts,


  • quinnquinn Registered User
    edited June 2008
    reinstalling windows is never, ever the answer. please find troubleshooting instructions here.
  • steelcondosteelcondo Registered User
    edited June 2008
    Hi Quinn,
    thank you for taking the time.
    You're right, reinstalling windows is never the right answer....though as the nuclear option it is undeniably effective.

    Anyways, I ran the logging utility as you suggested and have attached the result. Is it suggesting I'm out of disk space ? I have 9.4gb free on my system drive; the requirements are only for 200mb. Just in case I tried installing to my other internal hard drive with over 100gb free and it would not install there either.

    Before running the logger I tried Paul's regedit fix to no avail. I've also used ccleaner to try and remove any garbage from my registry.
  • steelcondosteelcondo Registered User
    edited June 2008
    After reading a post from someone who had the same problem, but with version 2.4.0, I tried their solution - installing without the FPS loopback adapter - and it worked. So my issue was not SP3 related as I had thought. I spent my initial troubleshooting time in that direction because of the technote and all the related posts.

    Too bad the installer couldn't give me an error message indicating the cause of the failure. Or proceeded with the install and simply informed me that it was not necessary to install the loopback adapter. It would have saved me a bunch of time. Perhaps in the next incarnation.

    thank you again for your helpful post, Quinn.
  • quinnquinn Registered User
    edited June 2008
    i fully agree that the installer needs some work.

    in this case, specifically, the custom action tasked with installing the loopback adapter is hard-coded to get its info from C:\, and completely fails when the the system partition is, in your case, F:\.

    again, totally not Windows's fault, and re-installing to F:\ would have left you just as frustrated. glad you got it "fixed", though.

    and if this saves anyone some time:
    • in the above attached MSI log, just prior to 04:02:38:609, the Custom Action using ConfigFPSLookback.vbs (Patrick Hutchinson, 2/15/08) returns 3 (failure).
    • should use %WINDIR%, not C:\
    • devcon is not redistributable...
  • zigzagphzigzagph Registered User, Administrator, HES Staff
    edited June 2008
    After further review Quinn is correct. Apparently my cleanup of the script did not get checked in as expected. I have ,again, changed the script to use environment variables instead of the current hard coded value. I wish that this problem had come to my attention a little earlier to avoid any user frustration. Sorry for any inconvienence.

  • bradpepebradpepe Registered User, HES Alumni
    edited June 2008
    This problem has been resolved in v2.6.0 (2071) which is available now...
  • steelcondosteelcondo Registered User
    edited July 2008
    Its extraordinary how quickly you guys found the source of this issue and realeased the corrective update. I first posted my issue on June 21, a Saturday. And you included the fix in the June 27 update.
    Very nice !
Sign In or Register to comment.