New Laptop Suggestion

Timothy BurkeTimothy Burke Registered User
Hi Guys,

I recently had my old laptop die and it is much cheaper to buy a new one than try to resurrect the old one. Does anyone have any suggestions for a new one? I primarily use it with a single universe usb widget and with one wing, to do lighting for corporate shows. So the are not very intense shows, a couple of color blast 12's, some mac 250's and some conventionals.

All the new laptops now are coming with Windows 7 64 bit. So im kind of stuck. I know from reading here that support for 64 bit for usb devices are not here yet. But is it possiable to use Windows 7's, Windows XP Mode with Windows Virtual PC, available on Windows 7 Professional and Windows 7 Ultimate. It allow you to run multiple Windows environments, such as Windows XP Mode, from your Windows 7 desktop. And it will use windows xp usb drivers. So can anyone tell me if this will work at all?

Comments

  • Richard RasmussenRichard Rasmussen Registered User, Hog Beta
    edited April 2010
    I was just in the market for a new laptop. I was at fry's and they had a Leveno laptop that came dual boot. XP and windows 7. Well they came XP and Vista but came with the Windows 7 Ultimate upgrade. I ended up going with an HP but I don't have to worry about usb drivers. I know that wasn't really your question but just wanted to let you know.
  • edited April 2010
    > it is much cheaper to buy a new one than try
    > to resurrect the old one.

    Having a laptop repaired can be quite expensive, but most common laptop problems are relatively easy to repair yourself, especially if it's a popular brand-name model. Figuring out how to disassemble a laptop can take a while, but most vendors publish service manuals that are quite helpful.

    Give it a shot, even if you can't repair it, it's cool to see how laptops are built internally.
  • Timothy BurkeTimothy Burke Registered User
    edited April 2010
    Im well versed in computer repair. The main hard drive is dead,needs a new one. I recently replaced the power supply, and the video card built into the mother board is starting fail. It defiantly is not worth repairing for the cost vs buying a new one. I only want to use this for my hog anyway. I have my nice new macbook pro for everything else. And before anyone says it I can not run it via boot camp because it does not have the support for the widget and wing. Which also makes all the emulators useless too. Not to mention the money for buying windows is half the cost of a new pc laptop. So Im stuck.
  • MLorenzMLorenz Registered User, Hog Beta
    edited April 2010
    I just bought an XP-Licence (official one, no copy or used) for 89 Euro from Amazon.
    So i would go with my Macbook Pro, Bootcamp and XP.
    I run XP on my macbook Pro in Parallels and Bootcamp, works fine with all Wings.

    So you must have Windows 7 on your Bootcamp-Partition?
  • Timothy BurkeTimothy Burke Registered User
    edited April 2010
    No, I have not installed window on my mac yet. You were able to get the wings to work?
    What about the widget? That is the most important thing. From what I have read on here that the widget will not work. I know boot camp did put out new usb drivers not to long ago. I wonder if that fixed it, anyone out there running a setup like this?
  • MLorenzMLorenz Registered User, Hog Beta
    edited April 2010
    At the moment i have running XP on bootcamp on my Mac Pro. I use the same HD for Parallels and also Bootcamp. Have a single widget, a programming-wing and and DP8000 attached to it. All working without any problems in Bootcamp and Paralles.
    I have Bootcamp 3.1 installed.

    Under Windows 7 there is a problem when using widgets. Cause there the drivers are missing (64-bit version). Which has nothing to do with bootcamp, Highend did not yet programmed them. This is also on non Apple Computers.
  • Timothy BurkeTimothy Burke Registered User
    edited April 2010
    Thats great :) What service pack are you using for xp on bootcamp?
  • MLorenzMLorenz Registered User, Hog Beta
    edited April 2010
    just upgraded to SP3, but it also worked with SP2
Sign In or Register to comment.