dp 8000 not booting

jussikamunenjussikamunen Registered User
We were updating hog 3 from 3.1.2 to 3.1.4.
Console software updated ok and working.
Dp2000 software updated ok and working.

Then the dp 8000 didn´t start to update.
So we tried forcing with pressing left button from dp8k when powerup. Nothing.
We ended up trying pressing all three buttons while powerup.
End result was that the dp8k isnt booting up any more at all.

If it is booted with all 3 buttons pressed the following happens:

First there is a lot of boot info runnning and eventually it goes to loop written below:

PXELINUX 3.71 3.71 Copyri
ght (C) 1994-2008 H. Peter
Anvin
Loading dp8000/vmlinuz-2.6
.26.5-dp.8k.....................
........................
Loading dp8000/intramfs-d
p87k_1.0_i386.cpio.gz........
.............................
.............................
....................
I/O Board Disconnected

At this point the Hog-Net Link light turns off and back on in approx 5 secs.


I/O Board Connected

And then dp goes back to beginnig of PXE... (loop above)


Then if is just turned on OR hard reseted (with center and right while poweron) a lot of info comes and everything stops to:

eth0: 10/100 speed: disabling TSO

and then nothing...

Havent had similar problems previously.
DP8k worked just fine before this.

Any ideas? Running out of buttons to press while powerup...

Comments

  • edited February 2010
    Holding a single button at powerup won't help in this case. Holding any single button forces the I/O board firmware to reload, and your I/O board appears to be working fine.

    Holding all 3 buttons will force a main firmware reload, which is what you need.

    Try connecting the DP8000 directly to the console with a crossover cable and nothing else attached to the DP. Then hold down all three buttons and turn on power. Do you get the same behavior?
  • jussikamunenjussikamunen Registered User
    edited February 2010
    Eric,

    dp8k still not working.
    Direct connection with crosscable dp8k-hog3.
    Tried first with the ip that we use -> boot dp8k with 3 buttons pressed.
    Same result as earlier, ends up running a loop as descibed earlier.

    Then I changed console IP to default settings.
    Again boot with 3 buttons.
    Now it went a bit more, but still stopped at some point and only
    said retrying or reconnecting or so...

    Then a third try with same setup.
    Now dp8k doesnt start to do anything. Only says forcing software reset (or something similar, can´t remember exatly).

    Didn´t try 4th time.

    I think I will contact our HES distributor on monday. In any case.
  • edited February 2010
    I'm afraid I don't have any other suggestions for you. You appear to have tried all of the normal troubleshooting procedures. It's possible there is an internal hardware problem.

    If you have a chance, you might want to load Hog3PC on a computer and try reloading the DP8000's software from that. Also, try a different network cable.

    If you use 3PC, you'll need to make sure that "Enable boot server" is selected in the network options window.
  • jussikamunenjussikamunen Registered User
    edited February 2010
    After many cable changes and tests without any result the dp8k was sent to a HES dealer. If they cant wake it up I believe it will be replaced. Now stuck again with dp2k for a while...
  • Pro-LightingPro-Lighting Registered User
    edited February 2010
    I´m having the same problem with a dp8k, in the same situation, when updating to the latest version (3.1.4)
    DP8k seems to be dead , not booting, and is not working anything, just get "freezed" in I/O Board Connected
    any updates in this?
  • jussikamunenjussikamunen Registered User
    edited February 2010
    No updates on this yet.
    I will send more info as soon as I get some myself.

    I still think two malfunctioning dp8k´s can be bad luck. Third one would be worth digging a bit deeper...
  • Pro-LightingPro-Lighting Registered User
    edited February 2010
    Jens helped me with this issue. (thanks again!)

    Boot until it get freezed. The dp will reboot itself after a time.
    when this happens, force firmware download (the dp connected to the desk...).
    This has solved the situation.

    First the dp booted correctly without doing anything after several tries.
    But when switch it off and on again the same problem happened.
    After forcing the upgrade in that way, is working OK.
  • jussikamunenjussikamunen Registered User
    edited February 2010
    Followup on dp8k problem: we got a new dp8k last week.

    Excellent work HES.

    But still no info on our previous dp and did it ever wake up...

    BTW, we just got a Roadhog Full Boar as secondary console :hogsign:
  • edited February 2010
    Can you give me some more details about your setup? How is your network configured? I just received the unit that came in for service, and it worked perfectly. I was able to load software, join a show, and control fixtures.
  • cpoguecpogue Registered User
    edited February 2010
    We had the same problems with the DP8k uploading to V3.1.4 and the previous v of software. We had to set the console up to "Use default IP settings" and "Enable DHCP and Boot Server" in the control panel, then(removing the DPs from the network) connect a crossover cable straight from the HogNET output to the HogNET input of the DP8k. You'll then do a 3 button restart (unplug, hold 3 buttons and cycle power) and it should download the software and boot correctly. Then you have to go back and reset your network IP Address if you're using custom IPs.:)
  • jussikamunenjussikamunen Registered User
    edited February 2010
    Eric:
    details about setup:
    Hog3+dp8k in network with 10/100/1000 switch.
    Connected to hog3: 10 fader usb wing, 2 monitors.
    We had custom ip's first when we had this problem.
    With this setup we tried 1 button and 3 button boot to dp.

    Then we changed to default ip settings and direct connection with crosscable. Same result. At this point the dp didn't wake up to any software any more, so we couldn't make changes to dp menu setup. Tried 1 and 3 button boots, details in previous messages.
  • edited February 2010
    cpogue is correct about the network setup. The settings he recommends should work in all cases. A single console with a crossover cable to the DP (It must be connected to the console port, the fixture port should not be connected to anything), default network setting, and DHCP & Boot server enabled.

    If a DP8000 gets a corrupt software update, it will make increasingly persistent attempts to reload. It will try again, then it will reboot and try again, then it will try and boot from the network and re-load the entire flash image (For those of you with an IT background, it uses the PXE protocol to boot from the network and completely reload the internal flash).

    If all of this still doesn't work, it will keep trying to boot from the network every two minutes until it finds a software server. That's why you see it sitting there scrolling the "connected" and "disconnected" messages repeatedly.
  • improveimprove Registered User, DL Beta
    edited February 2010
    Hi there,

    Same problem with us. Updated desk to 3.1.4 today, after putting desk back into network and connecting to DP8K the DP want to be updated. Doing so results in exactly what has been described before in other posts...

    But what confuses me is : In a normal operational environment. So fixed install in venue with Full Boar and DP8000 i should be able to run updates like this without having to change network settings... I got a network with switches (GB) and wireless laptop for editing purposes... So fixed IP adresses and then these problems with updating software... It's not what you would expect!!
    DP8 is in the dimmer room so it's not easily accessible from where the desk is... And from the desk you get no info on what's happening.

    Is there a specific procedure to follow when updating DP's so i can avoid this next time???

    Fons
  • edited February 2010
    In most cases, when you upgrade the console, it will detect that there are nodes on the network with old software, ask if you want to update them, and install the new software. If your network is setup properly, it will work without any network changes.

    The procedure I'm describing should only be used when you have a DP with corrupt firmware, or when an upgrade fails irrecoverably. Even then, the failsafe recovery procedure should work across a network.

    The reason I recommend using a crossover cable when you need to recover from a failed upgrade is that it eliminates any external variables. I frequently see networks that have rogue DHCP servers, or other devices that the operator isn't aware of. Spanning tree related delays can prevent PXE from working properly and cause the netboot to timeout before the switch port has entered the forwarding state. Some network management features intercept PXE and don't pass it along to the console.

    By using a crossover cable, you eliminate all of these variables and it may help you get your unit back online more quickly after an interrupted upgrade.
  • jussikamunenjussikamunen Registered User
    edited March 2010
    Eric,
    Sorry to say I don´t have any new info for you.
    We dont have any other devices in hog3 network so nothing should be disturbing system.
    We did try forcing firmware with cross-cable. And left it trying for hours without result and I also asked also a coworker to doublecheck what I was doing.
    It just didin´t work.

    But fast responces and a new dp was excellent service and made it possible to us to continue working. So thanks for that (and also thanks to Valo from Soundata Finland).

    We now have a Roadhog Full Boar with dp2k (now in artnet mode) as a secondary system / backup so updating now two consoles... more exitement to life...:hogsign:
Sign In or Register to comment.