Timecode Comment Macro not working consistently

z6p6tist6z6p6tist6 Registered User
Full Boar v3.0.3

I am working on a dance show.

Each piece is programmed on its own cuelist (with timecode), and each cuelist lives on its own page.

Song 1 = Page 1 / List 1 on Fader 2
Song 2 = Page 2 / List 2 on Fader 2
Song 3 = Page 3 / List 3 on Fader 2
(etc.)

There are about forty pages and lists like this.

Cue 1 of each list is a setup cue (in blackout) and is played back automatically via Capture Activity (when you switch to the page). This cue has a comment macro that says DT1>100:ETx, where 'x' is the relevant list number.

So, on Page 2 (List 2), Cue 1 has a comment macro that says DT1>100:ET2.

This should in theory force all of the timecode to be disabled on lists 1>100 then enable timecode on the current cuelist.

My problem is that this only works about half of the time that I switch to a new page. Capture Activity always works (the first cue always fires) and all of the timecode is always disabled, but the current cuelist's timecode is not enabled about 50% of the time.

Questions?

PG

Comments

  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited April 2009
    I think you need to split up your comment macro:

    Instead of DT1>100:ET2
    Do this DT1 : ET2 : DT3<100

    This way the console isn't trying to disable and re-enable timecode for list 2 all in one comment macro.
  • z6p6tist6z6p6tist6 Registered User
    edited April 2009
    Yeah, I'll do that.

    But am I correct that this seems well within the documented functionality? I would assume that these commands are supposed to be handled in the order they're entered, which should make this a very reasonable (and clean) way to program this.

    Regards,

    Phil
Sign In or Register to comment.