v2.6.0 H3PC wheelset bug (2071)

rosswillrosswill Registered User, Hog Beta
Navigating to color on wheel set crashes program with Catalyst V4 patched.

To reproduce with my attached showfile:

Go to prefferences, wheel sets, color.

Thanks Ross

Comments

  • teericksonteerickson Registered User, HES Alumni
    edited June 2008
    Ross,

    Thanks for the report. I'm looking into this now. Would you be willing to email your show file to me?

    Thanks.
  • rosswillrosswill Registered User, Hog Beta
    edited June 2008
    Yes trying upload is failing will email it in.

    Ross
  • rosswillrosswill Registered User, Hog Beta
    edited June 2008
    Sent it to support@flyingpig.com

    Thanks Ross
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited July 2008
    Ross

    Thanks for the information. We were able to reproduce the the problem and have logged a bug #11995 for this.
  • teericksonteerickson Registered User, HES Alumni
    edited July 2008
    Ross,

    I was able to track this down and get it fixed.

    We had to add some new functions to our library for the SHOWPIX fixture and those functions are referenced in the SHOWPIX wheelset file that is included with the v2.6 software package. If you import this preference file into an older show file that does not include these functions, when you switch to the wheelset editor pane of the preferences window and it tries to draw the wheelsets, it will fail and the desktop will crash.

    The best way to avoid this problem (or correct it if the import has already been done) is to merge the fixture library included with v2.6 (library v4.1.27) into the show.

    I'm not sure yet what release this fix will be included in, but I'll let you know as soon as I have that information. Thanks for your help finding this.
  • rosswillrosswill Registered User, Hog Beta
    edited July 2008
    Many thanks Tom,

    Ross
Sign In or Register to comment.