Hog2PC Midi In Driver Error

srileysriley Registered User
Hi,
I'm running Hog2PC 3.4.3.123 with a WholeHog 3 Programming Wing. Had to send the Programming wing back to High End to fix a USB problem, (laptop wasn't communicating with it properly). Got it back the other day and the USB problem has been fixed, however now everytime I start Hog2PC I get an error message saying "Midi In Driver Error - please try again: : A device ID has been used that is out of range for your system." I'm guessing that midi id for the Programming wing got changed somehow, but I have no idea how to go about changing it. I'm sure it's something really easy and stupid, but I am at a loss and getting very tired of running the show off of the virtual wing.

Thank you!

Comments

  • Marty PostmaMarty Postma Registered User
    edited November 2007
    Do you have MIDI IN enabled under the Control Panel?

    If so, and you aren't using it, then turn it off.

    Also try right clicking over the blue control surface and select "config". then be sure your MIDI settings are correct there as well.

    While you're there, check that the USB address of the wing is assigned to the correct location via the drop down menus.

    Hope this helps:)
  • srileysriley Registered User
    edited November 2007
    thanks, disabling the Midi In did get rid of the Error massage. The wing is still not responding though, (lights up briefly during startup and trackball works, but nothing else responds, LED's don't even light up). I've tried switching power supplies, USB cables, etc. and according to the Device Manager in Windows XP the USB is working properly.

    I'm thinking the Midi In may have been a red herring and the problem lies elsewhere. Any thoughts?

    Thanks!
  • Woodj32177Woodj32177 Registered User
    edited November 2007
    Are you sure there are not any devices in the Device manager that are showing up as "unknown device"? If there are, you can uninstall those and you should be able to reinstall the wing, and it should work after that..
    Otherwise, you may have a problem with the wing..
    Are you sure it is enabled in Hog PC?
    Joshua Wood
  • srileysriley Registered User
    edited November 2007
    In Device Manager under "Flying Pig Systems Devices" I have the DMX512 Widget, the Playback Wing and the Programing Wing and according to Windows all is well. If I go to Settings -> Control Panel -> Bus Devices it says "not found" under wing status. I haven't changed any settings since getting the Programing Wing back, how would I go about re-enabling it?

    Thanks!
  • Marty PostmaMarty Postma Registered User
    edited November 2007
    Have you verified that you have the proper USB address assigned? The fact that the LEDs flash when it powers up seems to lead me to think it is not.

    Right click on the blue control surface.
    Select "config..."
    Look to the right-middle of the Config window.
    Where it says "Programming Wing" click the arrow to the right of "Main"
    Select the wing's USB address (usually 4 digits, but possibly 3) from the drop-down.
    Select OK
    If no numbers appear in the drop-down, then your system is not seeing the wing. It is then either a driver issue or a bad USB cable.

    Hope this also helps.:)
  • srileysriley Registered User
    edited November 2007
    Unistalled and re-installed HOG2PC and re-enabled the Programing Wing under the Config menu and, thankfully, we are back in business.

    Thank you both for the help!
  • Marty PostmaMarty Postma Registered User
    edited November 2007
    Great! Glad you are up and running again.:hogsign:
Sign In or Register to comment.