(1618) Bug Report: Erratic MSC on IOP

jabadgerjabadger Registered User
edited May 2007 in Wholehog Lighting Control
Name: Badger
Date: 5/10/07
Software Version and build number: 2.1.0 (1618)
Number of displays: 0
Connected USB Devices: 0
Networked Devices: RCU, 1DP, 4IOP

Boot up and start sending MSC Go commands to one IOP. Change cable over to different IOP's in the system, messages are missed up until about 30-40 seconds then some messages are taken. MSC into back of console worked perfectly fine. Regressed show to 1.3.9 and had no issues with IOP's.

PSA: IOP's are bad right now kiddies, use a direct MIDI link to your console/RCU and/or a USB SMPTE Widget in the mean time. Or if you're like me and you can't do either of those, use 1.3.9 or earlier and don't use 2.1.

Comments

  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited May 2007
    Hey Jason,

    I am looking into this in the lab along with the MSC issues you were seeing at Space Mountain in Tokyo. As far as this issue is concerned with MSC coming into an IOP... I am seeing that our playback process is throwing away a lot of the MSC messages because they are "out of sequence". So, to verify that you and I are seeing the same thing, could you please open the event monitor (Pig+Open+1) and see if when you swap the Midi cables between IOPs if you are getting a series of messages in the event monitor that are along the lines of "Tossing go cuecue #, since it is out of my sequence".

    -Chris Muenchow
  • jabadgerjabadger Registered User
    edited May 2007
    I needed to go ahead and put 1.3.9 in to get the show up since I'm leaving the country soon. I had tried to get the dang event monitor open earlier in the day (when I was running 2.1) and couldn't on the rackmount. It's Ctrl-Esc-1 right (with MAP on)? I didn't have a number pad so maybe that's why?

    Anyhoo, keep hitting the same message over and over when you switch to the different IOP, it seems after a while of the same message, it finally gets through (until you change messages again). What you described would make sense. I could probably give it a go when I get back to the states.
  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited May 2007
    Alright, sounds good. I am going to compare my tests on 1.3.9 and 2.1.0 and get a defect open for this.
Sign In or Register to comment.