fade time with macros

sandersander Registered User
Is there a way to fade out a chase, or some endless linked follow-cues, running in an other cue-list than the active chooser using a macro command. So the chase is still running, and fading out. The macro should give the fade out-time. To mine opinion the syntax would be, for example: FM8/0t10, this is not working, M8 fades in 0s. to 0. I am only allowed to do this with RM8t10, but then there is a halt at the cue that was running in the chase and M8 releases in the given time. But I want to see the chase slowly fading out. Does anyone know a solution?

sander

Comments

  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited March 2007
    Currently there isn't any implementation for applying timing to macros but I do believe that I have a decent work around for you...

    How about creating a virtual cuelist with a cue that fades all of the fixtures in the chase to zero. Then you can use a macro (GL#) to fire that list. The chase will fade out as well as continue to run. You could then create a second cue in the virtual cuelist to fade the fixtures in the chase back in.

    Work of caution with this workaround: If the only thing running in the chase is intensity values then you will need to set the chase to persist on overide so that the chase doesn't release when the second cuelist faders everything to zero.

    Let me know if this works for you.
  • teericksonteerickson Registered User, HES Alumni
    edited March 2007
    Sander,

    Chris's workaround should take care of the job, but you may need to make your "fade out" cuelist higher priority than your other lists so that it doesn't get stomped as the chase continues to run.

    We do have plans to implement timing for comment macros. This is currently logged as feature request #4528.

    Thanks.
  • sandersander Registered User
    edited March 2007
    thanks,
    but there is still a problem. the chase is fading out, but also stops chasing, and that's what we don't want to see. or did i misunderstoot some priority-things?
    the timing was once, or still implemented for the 'release'-macro, though?
    ciao,
    sander
  • teericksonteerickson Registered User, HES Alumni
    edited March 2007
    Sander,

    As soon as you release a list, whether you press release or use a comment macro, it stops the execution of that list.

    If you want the chase to continue running as it fades out, your best option is to follow Chris's suggestion above.

    Create a new single-cue cuelist that takes the intensity of the fixtures in the chase to 0%, then when you want to fade the chase out, execute this new cuelist. The chase should continue to run as the fixtures fade to 0.
  • lbickfordlbickford Registered User
    edited March 2007
    Thank you Sander for this post and thanks for all the great help from everyone.

    I am trying to do the same thing with an effect.
    I have an effect cuelist written that runs in a random continuous loop to make 6 intensity parameters chase. This cuelist is triggered by a macro in my main cue list. I have now written a 1 cue cuelist that takes all 6 intensity parameters to 0. (all's well so far)

    When I trigger the "fade" cuelist the "chase" cue list stops at whatever cue it was currently on and fades that intensity out. The "chase" cue list continues to run, but the intensity parameters in the chase are forced to 0 by the "fade" cuelist. But, I can't get the chase to continue as the lights fade out.
    The only way I can get the effect I want is by attaching the chase cue list to a master and manually fading it down.
    It would be nice if I could trigger a macro to fade that master, but unfortunately I can't get that macro function to attach properly. I can only release the master.

    TIA for any help,
    Laura Bickford
  • bellonsbellons Registered User, Hog Beta
    edited March 2007
    Hi Laura, I reckon you have to set your chase list to persist on override for it can get stomped once you trigger your fade out list. If you have only intensity information in your chase list as soon as you trigger your fade out list (that has intensity information as well), your chase list gets overridden and automatically releases. That's why you're seeing your chase list stopping at current cue when the fade out cue is executed. Just remember that if you have set your fade out list to have a higher priority if you assert your chase list you won’t see any intensity at all for this parameter is still overridden.
    If you want to use a comment macro to fade out a master that’s possible but you won’t be able to set a fade out time for this option is not available yet.
    FM#/0à fade master # to O%.
    Marco
  • bellonsbellons Registered User, Hog Beta
    edited March 2007
    I did a couple of tests and apparently when dealing with chases things are little bit different.
    That’s what I did:
    1 thru 10 @ 20 record 1
    1 thru 10 @ 40 record 2
    1 thru 10 @ 60 record 3
    1 thru 10 @ 80 record 4
    Set the cuelist to chase.

    Did another cuelist i.e.:
    1 thru 10 @ 0 record 1

    I did trigger my chase list (without setting it to persist on override). Now I have my chase list running.
    When I play my fade out list, my chase list gets overridden but doesn’t get released.
    As the chase list keeps running, doesn’t reassert itself as expected and the fade out list (nor higher priority neither set on persist on override) keeps on controlling the intensity for fixtures 1 thru 10.
    Now I deem that chases are treated as a whole. By being a chase can’t get released and it is left running on background but gets overridden for the latest intensity information has been triggered by the fade out list.
    That’s what I did figure out. Don’t know if I’m missing something. Please Correct me if I'm wrong
    Marco
  • lbickfordlbickford Registered User
    edited March 2007
    Marco -
    Thanks for your responses.
    I tried exactly what you said and i still get the same result. I trigger the chase via a macro. Then I trigger the fade out cue list. The chase pauses at whatever step it is currently on and fades that intensity to 0.
    If I open the Cuelist directory I can see that the chase is still running. However, all of the parameters are at 0.

    Last night I found a post that explained how to achieve a fade out of intensities while the effect is still running.
    http://forums.highend.com/showthread.php?t=2446

    In this post it is explained that you should attach the chase cuelist to a master. Then you write a cuelist that has 10 steps, each one fading the chase master down by 10% until it's out. When you want to fade the chase out, you trigger this cuelist by macro + the faders steps down. It's a bit of a complicated workaround, but it does exactly what I want.

    Anyone have a simpler solution??

    :hogsign: Laura
  • DrEadDrEad Registered User
    edited March 2007
    Hi guys... was the macro fade times implemented in v2.1.0?

    Hoping!!

    Craig
  • teericksonteerickson Registered User, HES Alumni
    edited March 2007
    Craig,

    Most comment macros do not support fade time syntax. This is definitely on the to-do list.
  • SourceChildSourceChild Registered User
    edited March 2007
    Something we are forgetting to consider here guys is that if a "chase" list is a dimmer chase list, then when a "fade-out" list is triggered, it will take precedence over the current step in the chase. If its priority is higher, the effect will be that all intensities in the new lists will persist.
    Try to look at this from a different perspective.

    Create an FX dimmer chase. Build your intensities on one master. Then create an FX with no dim priorities on a second master.

    Say you have 4 lights chasing. Set the FX to STEP, in offset type 0 thru 270, enter. Set length to 25% and size to 100%.

    Now fader 1 is the intensity of all four. Fader two will manually fade the dim size from 100 to 0. If fader 1 is at zero, the chase runs.

    Now on fader 2, you can brin down intensity or create a second cue in fader two's list with size at 0% an the timing you define is the fade-out time.

    Please note, the level of fader 1 in this scenario will have different effects on the visible output.

    To simplify even further, include intensity at 100% on your FX chase in step 1 and 0% in step 2 and you have a single vmaster chase.

    The only thing you loose in this is instant rate control from the wheel (hog 3, not pc, ipc, or rh). If however this is just some chase you are triggering from a macro command, I assume it's a vmaster you don't have ready access to anyway.

    A solution for this, is to open your editor of step 1 and record a view. Then, when it runs, turn off blind and you have rate control. You can even build that view grab into a macro on your show page.
Sign In or Register to comment.