MSD and Hog 3 PC Connecting...

Sarriss254Sarriss254 Registered User
Hi all

I'm running MSD 4.8 and Hog 3 v 2.0.x.x.x (latest download). I've downloaded and installed the connectivity app from FPS. When I fire up the Visualizer, when it launches the Hog 3 connectivity app, I get an error that says...
icon_smile_question.gif"Unable to find correct functions in HogDLL while initializing."icon_smile_question.gif

Visualizer loads fine, etc, but if I go to the "select driver" area, it says Hog 3 PC Link is selected, but under that it says "There was an error during initialization"

I've read all required documents and done everything suggested, but no dice...

I also heard a "rumour" that this setup is not working yet?!?

Please can anyone assist me?

Thanks
Sarriss

Comments

  • bellonsbellons Registered User, Hog Beta
    edited November 2006
    hi heidy. to get your problem sorted out copy and paste the file attached into the Wholehog III Connectivity folder or system 32 folder. hope this helps. Marco
  • Sarriss254Sarriss254 Registered User
    edited November 2006
    Thanks Marco, I'll try it and get back to you...
  • Sarriss254Sarriss254 Registered User
    edited November 2006
    Ok, I tried the attached file and it's still not working. The jpg below shows the error on starting...

    It hasn't changed with the new DLL file added...
  • Emiliano MorgiaEmiliano Morgia Registered User, Hog Beta
    edited November 2006
    Sarriss254 wrote:
    Ok, I tried the attached file and it's still not working. The jpg below shows the error on starting...

    It hasn't changed with the new DLL file added...

    What Gerald Say about the issue ?
  • RobfulRobful Registered User
    edited November 2006
    Hi Heidi,

    It may be that you need to "register" the MFC71 within the System 32 folder. See the thread below for more information:

    http://forums.highend.com/showthread.php?t=2966

    If that doesn't work, you could try copying the MFC71 into your MSD folder. I don't know if that will work but that's what i needed to do with Capture.

    Robert
  • Sarriss254Sarriss254 Registered User
    edited November 2006
    I tried all you suggested above, and tried "registering" the file as suggested in the other thread (and got an error!:angryfire: something about no source...)

    And still not working!!:sad:

    :1zhelp: :sad2:

    ?!?!?!
  • teericksonteerickson Registered User, HES Alumni
    edited November 2006
    Sarriss,

    The connectivity driver should definitely be working with Martin Show Designer.

    The first thing I would try is making sure that you're logged on to your PC as an administrator and re-installing the Wholehog 3 Connectivity Driver. The current version of the driver is v1.1.0.59.

    Please let me know if this doesn't take care of the problem.

    Thanks.
  • Sarriss254Sarriss254 Registered User
    edited December 2006
    teerickson wrote:
    The first thing I would try is making sure that you're logged on to your PC as an administrator and re-installing the Wholehog 3 Connectivity Driver. The current version of the driver is v1.1.0.59.

    Yes to all the above. The only things I can think of are that

    1) I didn't do a full install of my current version of MSD 4.8.0 but did an upgrade from 4.7.x.x

    and

    2) Try to download the 4.8.3 upgrade :Eyecrazy: (dodgy prospect with my internet connex...)

    I have another question on a slightly different theme, but still related...

    If I get this up and working on my PC, can I then use my network port to plug my Hog 3 to my PC to run the visualizer, without using the DP?
  • Marty PostmaMarty Postma Registered User
    edited December 2006
    Sarriss254 wrote:
    If I get this up and working on my PC, can I then use my network port to plug my Hog 3 to my PC to run the visualizer, without using the DP?

    Sarriss,

    You should be able to connect a PC Visualiser directly to the H3 console, just make sure you are using a crossover cable, or run both through a switch.
  • teericksonteerickson Registered User, HES Alumni
    edited December 2006
    Sarriss,

    Marty is correct. Hog 3PC and the Wholehog 3 console can connect directly to visualizers (WYSIWYG, ESP Vision, MSD, and Capture) without any DP2000s or DMX widgets. You can run Hog 3PC on the same PC as the visualizer, or you can run separate PCs that are networked.
  • Sarriss254Sarriss254 Registered User
    edited December 2006
    So the interconnect thing is great... nice to know for future endeavours, but I still need to everything else to talk to each other on the same PC first, which is still not happening...:no:

    Any thoughts from the gurus?:dunno:
  • Marty PostmaMarty Postma Registered User
    edited December 2006
    Sarriss254 wrote:
    I still need to everything else to talk to each other on the same PC first, which is still not happening.

    Hey Sarriss,

    You need to either have an active network connection for the porgrams to communicate on, or you need to install the Microsoft Loopback adapter.

    Hope this helps ya' out:hogsign:
  • Marty PostmaMarty Postma Registered User
    edited December 2006
    There is a very good description of how to do this posted by DAve Schultz in this thread:

    http://forums.highend.com/showthread.php?t=1715

    Look @ post #52....copy below:

    1.Click Start, and then click Control Panel.2.If you are in Classic view, click Switch to Category View under Control Panel in the left pane.3.Double-click Printers and Other Hardware, and then click Next. 4.Under See Also in the left pane, click Add Hardware,and then click Next.5.Click Yes, I have already connected the hardware, and then click Next. 6.At the bottom of the list, click Add a new hardware device, and then click Next. 7.Click Install the hardware that I manually select from a list, and then click Next. 8.Click Network adapters, and then click Next. 9.In the Manufacturer box, click Microsoft. 10.In the Network Adapter box, click Microsoft Loopback Adapter, and then click Next. 11.Click Finish. After the adapter is installed successfully, you can manually configure its options, as with any other adapter. If the TCP/IP properties are configured to use DHCP, the adapter will eventually use an autonet address (169.254.x.x/16) because the adapter is not actually connected to any physical media.

    Note By default, TCP/IP properties are configured to use DHCP.
    Hope this helps you out and it should.
  • bradpepebradpepe Registered User, HES Alumni
    edited December 2006
    FYI...

    You can also read the guide for installing the loopback adapter by clicking the link at:
    http://www.flyingpig.com/support/hog3/manuals/
    or directly download the PDF:
    http://www.flyingpig.com/support/InstallingandConfiguringtheMicrosoftLoopbackAdapterforHog3PC.pdf
  • Sarriss254Sarriss254 Registered User
    edited December 2006
    I tried to do this once before, but my PC kept freezing when I went to the 'Choose what hardware you're installing" page. I will try it again...

    :friday:
Sign In or Register to comment.