Bug Report - Keystroke Macro Recording Won't Stop

tbslytertbslyter Registered User, Hog Beta
I have tried recording numerous keystroke macros on several different consoles running 3.10 - 3.16 (Hog 4, Hedge Hog 4x, Nano Hog 4 PC) as well as several installations of Hog 4 PC running on both Windows 7 and Windows 10.  All seem to have the same glitch.  Once you begin recording a Keystroke Macro, it will not stop. 

Normally if you start recording a Keystroke Macro, you press PIG + MACRO and the recording stops.  The LED on the Macro Key stops flashing the Red Macro Symbol in the Command Line disappears and the Red Highlight on the Macro in the Macro directory stops glowing red.  

Currently, PIG + MACRO does NOT stop the recording and the only way I have found to get out of Keystroke Macro Recording is to Restart the Desktop or Exit out of the Showfile.  The issue occurs regardless of using physical keys on a keyboard or virtual keys on the digital face-plate of Hog 4 PC.

Since moving playback bars to external monitors and opening the Kind/Command Key window is NOT part of the view, keystroke Macros are VERY important on Hog PC, Hedge Hog and Road Hog console to properly position toolbars, playback bars and certain windows when starting up in certain layouts.

Hoping there is a simple and quick fix for this.

Travis

Comments

  • Gabbi_GriffithGabbi_Griffith Registered User, Super Moderator, HES Staff
    Hello,
    I have tried recording keystroke macros on my Hedgehog 4 and I have been able to stop them. What macro are you trying to record? What happens if you launch a new show and do record macro 1 Enter and then do 1,2,3,4 and then hold Pig and press macro does it stop? That is what I have been doing. I am running 3.16.0
Sign In or Register to comment.