Midi faders and encoders

Hello! I’m looking to add something like an akai apc40 to a pc rig for control over midi. To test some of this, I fired up my novation impulse 49 which has some faders and some infinite spin knobs I thought would be good for controlling the encoders. Well, I never got the faders to work at all and the knobs I could make talk to the hog encoder wheels, but only a small range. I did have to change the mode from7 bit absolute to 7 but relative but it was only changing part of the intensity encoders value range. 0 on the midi knob wasn’t 0% on hog and 127 on the knob wasn’t 100% on hog. What am I missing? Do I have to have something bomes midi translator or is there something I’m doing wrong? Thanks in advance!

Comments

  • datadriverdatadriver Registered User, HES Staff
    We've done extensive testing with the Akai ap40 mk2 with good results. Faders, knobs, buttons all work.
  • DarylnelsonDarylnelson Registered User
    Awesome! So I’m not missing anything? Just need the apc 40 and my laptop for what I described to work?
  • Gabbi_GriffithGabbi_Griffith Registered User, Super Moderator, HES Staff
    edited September 2021
    That's correct just the APC 40 and Hog 4 PC on your laptop.


    Checkout manual section 21.2.1 MIDI Map Editor for more info
    https://www.etcconnect.com/webdocs/Controls/HOG/HTML/en/sect-midi_note_input.htm


    Remember to put your encoders as MIDI Type: Controller in "relative" Mode
    Buttons like 1, 2, 3, full as MIDI Type: Note
    and faders as MIDI Type: Controller in "absolute" Mode

  • DarylnelsonDarylnelson Registered User
    Ok so when I bought the apc40 yesterday I didn’t have my pc with me. I was able to get everything working fine on my mac running hog on windows via bootcamp. Fired up my pc rig this afternoon and most everything is working except I can’t get the apc faders to control the hog faders. I can make the apc faders control an encoder wheel in hog so I know they are talking. Seems like it’s something weird with the faders on hog on this machine. Is there another setting within hog that I should check that may allow/disallow remote access to those? I also tried every mode in the midi map and none of them worked (relative, absolute, 7 but, 14 bit, etc)
  • datadriverdatadriver Registered User, HES Staff
    APC40 faders are 7 bit absolute. Make sure there is a playback item assigned to the master for the hog fader. For example, if trying to control fader 2, don't expect to see the Hog virtual fader widget 2 move on the virtual front panel unless there is a playback item on master 2.
  • DarylnelsonDarylnelson Registered User
    That was the issue. I didn’t have a playback assigned to that master. Thanks! All seems to be working now!
  • alsandyalsandy Registered User
    are faders always 7 bit Absolute?
  • datadriverdatadriver Registered User, HES Staff
    @alsandy No, it depends on the MIDI hardware being used.
  • YettiCYettiC Registered User
    Hi All, does the APC40 Mk 1 also work or is it just the Mk2 that has been tested? Cheers
Sign In or Register to comment.