Showfile Loading error

phayesphayes Registered User, Hog Beta
So here is a strange one. I have a showfile (3.15.1) that  loads into Hog 4 PC and onto a console from a backup file just fine, but when I log off and try to log back into the show I get an error that pops up that says Unable to retrieve object for ID 879 (sometimes this number changes) from parameters Array. The only way I can get my show to load is hard rebooting the console and loading the show from a backup. This seems to have all started after I removed some plot images and added a few new ones. I've tried started a new show and Merging all my data in and had the same result.

Thanks,

Comments

  • datadriverdatadriver Registered User, HES Staff
    The backup file that loads fine is actually corrupted. At log-off database items that are "marked" for deletion are physically removed. This procedure exposes the corruption in the backup on the next load of the unarchived and modified database. The parameters array error actually refers to functions on fixtures, so where your archive went south would have been in the addition/deletion/or change type of fixtures prior to any plot work. We have some work planned in an upcoming release to further reduce these types of errors
  • phayesphayes Registered User, Hog Beta
    Gotcha, Thanks for the explanation!
  • datadriverdatadriver Registered User, HES Staff
    I should add that "further reduce" does not mean an impending fix. We are looking at validating show files as we create a backup. As your backup is already bad, such work would not address that current archive. Rather, over time the community would collect backups that have gone thru much more stringent checking and validity tests. There is nothing worse than thinking your show is good only to find out later that it is not - some of us are operators too. Often there are various tricks that can be done to get out of a bad state in case you are considering the show lost. I'd suggest getting your showfile to our support team.
  • phayesphayes Registered User, Hog Beta
    Ahh, gotcha! I'll send it over to support.
Sign In or Register to comment.