Bug-Lag when usign encoders on Hoglet

Hello everybody, i recently upgraded my Hogon PC to 3.14 and I´m facing a strange behaviour after a while. When scrolling through  (a list or the output for example) by using Open+EncoderWheel (for up/down), the list doesn´t move along with turning the encoder. The scrolling just stops, and after a second or so it moves again. Same is happening, when I want to adjust Pan/Tilt for example.

At first, I thought, it would be in context with the network. I used a laptop with an own superwidget for Backup. Hog-/Fixturenet have their own NICs with different IP ranges, so both nets are separatet. PC with Hoglet had its four universes to ArtNet as well (there was no output on ArtNet). When having turned of the PC with Hoglet, everything went fine for a while, then the upper behaviour came up again. Didn´t have any problems with further versions

Specs of PC with Hoglet: Core i3 8100, 8 Gb RAM, 120 Gb SSD, 27" Multitouch (USB). Hoglet is the first series, it was bought in December 2016. I THINK its version is 2.3, but I am not sure.

Could it be that the patched ArtNet universes cause trouble, when they are not in use? I have to admit that in further versions I had not enabled any DMX-output over network, when having not used it

Tagged:

Comments

  • michaelgmichaelg Registered User
    *Update 2020-11-04: problem appeared again. No Fixture-Net was patched. Lagging when scrolling through lists, etc. seems to be fixable by restarting the desktop-process (haven´t tried when setting Pan/Tilt). No reports or logs were generated (as far as I have seen). Version of Hoglet: 1247-2.3(1,0) Version of External Widget: 12264--4.1(0,0)
  • Noah_AllenNoah_Allen Registered User, HES Staff

    On your PC, can you send me a screen shot of a few places? 

    • PC Specification,
      • System info (press windows key and type system info)
      • Hog 4 PC Control panel
    • System info tab
      • Hognet Tab 
      • Fixturenet tab
    • Processor settings(In the network window)
      • Output tab (If on 3.14.0)
      • sACN output HogNet traffic requires a network link that allows for Multi-cast traffic.
      • ArtNet output (If on 3.13.1 and below)

    Can you attach your show file with steps on how to get the lag to happen?

    -Noah Allen

    Product Support Specialist

    High End Systems, Inc.

    512.491.4206

    noah.allen@highend.com

  • michaelgmichaelg Registered User
    Hello Noah, I will do that today afternoon (Germany). I switched back to 3.13.1, I experienced this lag once. I cannot say how to securely reproduce it, but I think that it is likely to happen, when buttons like Open, Clear or Choose arepressed rapidly behind each other. But this may be just a subjective opinion.
  • michaelgmichaelg Registered User
    Hello Noah, show file and Fotos were sent to you.
  • michaelgmichaelg Registered User
    edited December 2020
    *Update 2020-12-05: Bug also happens with 3.12. Complete re-installation of dedicated pc for Hoglet didn´t work. Bug didn´t vanish. It doesn´t only happen with the buttons mentioned in the earlier post. BUT: the bug is traveling with the hoglet. I tried a different computer (with 3.14), and there I can provoke the bug within five minutes or so. I have to admit that when you turn the encoder wheels very slowly after the bug "happened", you can still get smooth pan/tilt movements or whatever you do with the wheels. But due to the fact that i do a lot of busking and not knowing exactly when it happens, it bothers me a lot. Were there any firmware-updates for the hoglet in versions after 3.12?
  • michaelgmichaelg Registered User
    *Update 2020-12-07: it seems that the bug is gone with a freshly installed Win10 Build 1909. Tested on 3.14.
  • spiroskspirosk Registered User
    Same problem here. Check it on a desktop pc, a laptop an a NUC. PC is a powerful machine (I7, 64gb ram, M2 HDD, 1060Ti ) Laptop (I7, 16gb ram. SSD) NUC is a hog dedicated (I7, 16gb ram. SSD). The encoders seems to freeze especially at pan/tilt and focus/zoom functions. Check it with different show files, older and fresh ones and also new show. Would like to avoid to reinstall windows. Too much trouble...
  • TGPTGP Registered User
    I am having the "same" issue. That is, when I used the physical encoder wheels on the Hoglet 4, the display on my monitor lags (as do the physical fixture) 1-3 seconds. It can reproduce it with a simple intensity change on a fixture. It started for me with widows update March 9, KB000802, OS Build 19041.867 and 19042.867. I am on Windows 20H2 OS Build 19042.867 When I back out that update, the issue goes away. The computer system is dedicated to only this application, nvidia graphics card, significant memory, etc.. All USB are directly into the computer. I am running HOG 3.15.0 (b.3121) I backed out that windows update and the issue went away so it certainly appears to be related to that update.
  • michaelgmichaelg Registered User
    edited April 6
    @TGP: I am not sure about that specific update since i already had the problem in the beginning of december 2020 on two different machines. I am currently running 3.15.0 on a Win10 1909 with all security patches installed, no problems. When switching to a laptop with up-to-date 20H2, the bug is there again. But I´m happy for you that you can work again :)
  • DsaveskiDsaveski Registered User
    edited May 13
    I have Same Problem. Have tried 3 different PC'S all with I7 windows 10 and desired specs as hog requires. Fresh install only works for a few minutes sometimes hours before the problem starts again. Using a nano hog4. Found running and effect then fanning example pan or tilt attribute really aggravates the lag to 3 seconds.
  • rolfwenzelrolfwenzel Registered User, Hog Beta
    Hey All, as Sarah was asking about the lagging encoders phenomena to post here with Details.. My Setup is: Inspiron 2350 AIO PC Nano with 02 x internal Super Widget connected to PC via USB 02 x Hog 3 Playback Wings, connected to PC via USB, Second PB Wing is USB looped through first wing. All outboard powered with Power Supply Windows 10 21H1 (but also with 20H2 etc) Use of Encoders very laggy most of the times, especially in Beam and Color, but also sometimes in Position.. Removing of PB 3 Wings doesn't change anything.. Playbacks run smooth
  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited July 20
    Thank you everyone for providing excellent insight and feedback into this issue. The symptoms you are reporting sound like they might be related to messaging between the USB device (wing) and the USB driver and/or host. For those of you still experiencing this issue I would like to ask you to try the following steps to see if it resolves the issue: 1. Open the windows task manager (ctl+alt+del) 2. Click on the details tab 3. Look for a process called WUDF Host (you might see more than one since you have multiple wings plugged in) 4. Right click on each of these tasks and set the priority to HIGH The priority changes do not persist through reboots and possibly not through application quit/restart so you'll have to keep an eye on it but this was the root cause of some USB LTC Widget frame dropping and its possible the WUDF Host is struggling on Windows again. If this resolves the issue it will help us to start to build a better understand of the root cause. If not, we'll keep digging!
  • DsaveskiDsaveski Registered User
    edited July 21
    I have tried changing WUFD priority to high but can still fault the problem after 10minutes of play.
    The issue doesn't follow playback only the programming section.
    I have found ramping encoders and running several effects + offsets really aggravates the problem.
    A reboot of the hog4 pc works for a few minutes then the problem appears again.
  • EclairissonEclairisson Registered User
    Hi, i also tried this but this issue persit.
  • phayesphayes Registered User, Hog Beta
    I'm experiencing the same. I also tried changing the priorities but it did not help. running a hoglet and mini wing 4 (3.15.1) on an Intel NUC NUC with 16GB DDR4 Ram, Kingston 256GB PCIe SSD, Intel Core i5-8259U Windows 10 Pro with the most current updates installed as of 7/22/21. There is also a dell P2418HT touchscreen attached. I've experienced this on all units in L8 as well as a on a real rig
Sign In or Register to comment.