Technospot issues

Hello,
I have 3 technospots that are acting up. I'm new to maintaining moving heads so could use some pointers to diagnose.

#1: no lamp on (not sure if other functions work properly)
-- I tried replacing the lamp and the ballast but still doesn't lamp on. does go through self test. When I first started looking at it, it went through self test then the screen would flash and wouldn't respond to dmx. after swapping out the ballast or igniter thing the screen started working and it started responding to dmx, but still no lamp on. The screen shows it thinks the lamp is on (i think) and i did a lamp on from my console.

#2: goes through self test, but when pan tries to find home, it doesn't register, it just keeps bumping against the pin thing that sticks up. Not sure how to troubleshoot this as I didn't figure out where the sensor is or what it even looks like.

#3: when power on, gives a low volume whine which seems either to come from the main power supply or the pan motor. Screen does not turn on I don' think. Guessing power supply trouble?

Additionally, they are missing a bunch of screws. It seems there are 3 or 4 main screw sizes used, does anyone know what these screw sizes are so I can order some to replace them. Also the lens mounts are missing some of the spacers (only two screws holding the lens on) so looking for these sizes also.

Thanks in advance
Sign In or Register to comment.