Technobeam firmware uploading

Hi,
I have several black label TBs all running v23.5 and recently acquired another (black label as well). The new acquisition had v21.A and I attempted a crossload to bring it up to the same version as the others. Sending unit went through all steps, and receiving unit's display reacted seemingly appropriately (flickers with UPLd displayed as the sender sends each block of code).

After sending unit displays DONE, receiving TB remains on UPLd. Power cycle now simply shows UPLd which I assume means the boot loader finds no valid resident firmware. I've tried several attempts with different DMX cables with the same result.

I see there is ECHO software that can manage fixture firmware, but requires either an upload dongle (costs more than the fixture(s)) or a HOG single universe widget. Since HES is now owned by ETC, I'm wondering if the ETC Gadget II USB DMX interface is, or will ever be compatible with ECHO?

Any suggestions as to what to try next to get firmware back into the TB? Or is it now a parts donor?

Thanks!

Comments

  • K9MikeK9Mike Registered User
    Well, after trying literally more than a dozen times using DMX cables with lengths:
    3 feet, 10 feet, 25 feet long... I decided to try one more time with a 50' cable... lo and behold... it worked.

    No idea if cable length had any bearing or if there were simply random bit errors due to a noisy environment, and the last time I just got lucky.

    Still curious if the ETC Gadget II will ever be supported by Echo.

    Thanks!
Sign In or Register to comment.