ArtNet Network changes between 3.7.1 and 3.12.0

dandan Registered User, Hog Beta
Hi,
I was in "The Anthem" venue in Washington DC, and was unable to control their rig via ArtNet despite several attempts, and reboots.
The house console is a fullsize Hog4, but they have it running on 3.7.1.
I had 2 fullsize Hog4s with me, and tried copying their network settings... and even tried loading their showfile into both my desks... and still couldn't control it.
The strange thing was being unable to set a Gateway.... their console had 0.0.0.0 as the gateway... and no matter what I entered into mine, it changed to 0.0.0.0 when I applied.

I have a copy of their showfile that I can send, as well as mine.

I guess the reason I am posting this, is that if they update their software, then their showfile willnot control their rig (As loading it into my desks proved)... so I am trying to pre-empt a support call from them.

Any thoughts?

Comments

  • nzpiemannzpieman Registered User
    The gateway shouldn't matter. You would set it to your router's IP so you can communicate outside your LAN (which you aren't doing with an Artnet Network).

    Assuming that you're definitely plugged into the FixtureNet Port not HogNet (you'd be surprised sometimes).
    Desk FixtureNet IP's and all Artnet Node IP's are in the 2.0.0.X range with a subnet mask of 255.255.255.0
    Link should be Up on the FixtureNet
    Under the DP the fixtures are patched into, make sure the ArtNet Outputs are active for each universe
    Reboot both the Consoles and Nodes.
    If they still haven't picked up the Artnet Stream via Broadcasting, then try a UniCast to the node IP address. Usually Nodes are fine for picking up broadcasting, and I've only had to do this with Arkaos Media Servers.
    If Unicasting doesn't work then you should try putting a Laptop on the network and running an Artnet Diagnostic tool like DMX Workshop or Artnetominator to verify that the Hog is outputting a valid Artnet Stream.

    The fact that their desk runs the rig proves that things are working from their network port to the fixtures. If you weren't using the cable their console was using then it's possible you had a bad ethernet patch cable or a network port patched incorrectly.
  • dandan Registered User, Hog Beta
    But why would there showfile not control the rig using either of my consoles?
    Same cabling.
    Only difference is software versions.
    Had no Artnet issues controlling rigs on other showdays.
  • cormacjackcormacjack Registered User, DL Beta, Hog Beta
    Hey Dan,
    I got a call from someone last week with a similar issue.
    They were using v3.11.0
    Console was "apparently" correctly outputting artnet on the correct universes/patched correctly but the device was seeing nothing.
    Went through the basics and all seemed well., advised a full install of the software, same showfile loaded again and the console came back to life and all was well.
    C
  • MLorenzMLorenz Registered User, Hog Beta
    Did you use broadcast or unicast?
    As there had been an issue.
    Also are they using pathport nodes? As they also having an issue (Pathport is aware of it and provided a firmware update afaik)
  • dandan Registered User, Hog Beta
    I tried broadcast in my showfile... theirs was set to unicast.
    All the nodes were PathPort... I will look for a firmware update and let them know.
    Thanks.
    D
  • stue austue au Registered User
    I have the same gateway resetting to 0.0.0.0 issue causing my iPad app not to be able to work correctly now
Sign In or Register to comment.