Order/speed comment macros are fired

dandan Registered User, Hog Beta
3.8.0 build 1577
Hog 4 fullsize

Bit of a weird one this. I have 2 issues/examples of changed behaviour.
The console used to send comment macro commands after the cue values were sent. I think this order has been reversed, and the macros are firing before the cue data:

Example 1
Master cue stack priority 0.
Fired master cue stack prority 0.
Cue 2 in master stack has dmx info for all fixtures & fires another stack with only colour info.
Previously, this behaved as if the master stack data was sent, and then the colour stack.
This is now behaving as if nothing happens... as the master stack’s data ltp’s the color stack.
Raising the priority of the color stack solves this..... but it worked on earlier software!

Example 2
A pan effect stack that I want to release at 2s until the end of the show when I want it to snap release:
Step 1 > pan effect (2s fade)
Step 2 > posn with no effect (0s fade)
Action at end of list = Add release end cue
So..... I can fire and release step1 with comment macros and it fades in and out the effect with 2s fade.
End cue of the show and I fire cue 2!
This should (time 0s) snap to a position, then auto release. It doesn’t. It releases with 2s and the position doesnt get fired. Even when I change the fade time of the position to 0.1s of similar. You still see the 2s release.
As if the “auto release” is firing before the cue dmx info.
I have solved it by adding an empty cue3 set to 0.1s wait time...... so the data from the cue 2 is definately sent. Thus snapping the position before auto-releasing.

Hope the above makes sense.
The behaviour has definitely changed since I upgraded the software.

Dan

Comments

  • dandan Registered User, Hog Beta
    I should note that the issues were not present in programming on 3.7.x using hogpc & wysiwyg on same machine.
    They were discovered when the show was loaded into 3.8.0 on a fullsize & connected to wysiwyg (and replicated when connected to the rig)
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    Hello,

    Sorry for the late reply. We will look into this and report back.
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff
    edited February 2018
    Hey Dan,

    This is a hard one as we are both going to the cue and releasing the cue in 0 seconds. We send the value but will never get to it as we start releasing immediately. My guess is wysiwyg may apply some sort of internal delay to ensure you see that position before releasing.
  • dandan Registered User, Hog Beta
    Ah.. OK.. so a case of WYSIWYG vs reality issues, that co-incided with a software update.
    Thanks for looking into it.
    D
Sign In or Register to comment.