HogConnect 3.4 vs HH with 3.3 to work with Light Converse

PitMan71PitMan71 Registered User
Will Hog Connect work with a HH4 with 3.3 Installed? If not where can I get HogConnect 3.3? OR must I upgrade console to 3.4? Thanks for the help.

Comments

Sign In or Register to comment.