How to create a stable profile for HOG 500

Hey everyone, so I have created a hog 500 profile for the Chuavet Color strip.

It is an RGB 4 channel LED bar. However i'm having some issues with how Chuavet configured the light as far as channels.

This light does NOT have a "dimmer" channel. It only has a RGB color mixing mode that allows the user to control each channel individually, but how you do this is to bring up channel 1, to DMX value like 85%. It also has a bunch of chases that I tried to program in as Macros, but I could not get it to work (inside the profile I made), this is the first profile I have ever written myself and I atleast have 80% functionality.

//-------------------------------------------------------
fixture = CoStrip
manufacturer = 99
product = 99
name = Color Strip
yoke = no


output = dmx

parameter = Colors
kind = c
default = 0
highlight = 0
crossfade = 0
type = htp8bit
range = 0, 255,%

parameter = Red
default = 0
highlight = 0
crossfade = 0
type = htp8bit
range = 0, 255,%

parameter = Green
default = 0
highlight = 0
crossfade = 0
type = htp8bit
range = 0, 255,%

parameter = Blue
default = 0
highlight = 0
crossfade = 0
type = htp8bit
range = 0, 255,%

parameter = Macro
default = 0
highlight = 0
crossfade = 1
type = lhtp8bit
range = 80, 89, ColorChange1, noauto
range = 90, 99, ColorChange2, noauto
range = 100, 109, ColorChange3, noauto
range = 110, 119, ColorChange4, noauto
range = 120, 129, ColorChange5, noauto
range = 130, 139, ColorChange6, noauto
range = 140, 149, Chase1, noauto
range = 150, 159, Chase2, noauto
range = 160, 169, Chase3, noauto
range = 170, 179, Chase4, noauto
range = 180, 189, Chase5, noauto
range = 190, 199, Chase6, noauto
range = 200, 209, Chase7, noauto
range = 210, 219, RGBMix, noauto
range = 220, 229, ColorFade, noauto

http://www.manualslib.com/manual/608660/Chauvet-Colorstrip.html?page=15#manual Here is the DMX channels and values

Comments

  • MadisonPandaMadisonPanda Registered User
    That first channel, the one I named "Color", that is the 1st channel that controls EVERY aspect of the light the other 3 channels only do things to interact with the first channels DMX value percentage. So when I put start affecting channel 1, in my "Color" tab on my 500, it flashes through a bunch of color presets, which is normal for this fixture, you can just select a color and you can record and snap through colors (which I didnt want to use because it looks cheesy), But if you keep scrolling past the presets around DMX value 210-219 it allows you to color mix that also allows you to DIM and black them out.... This is what I wanted to use the most of all but whenever I set the first channel to 85% (inside the hog) this allows me to color mix on them and it is smooth. But once I record the effect and create a cuelist, it records the effect but when I click the flash button or set up the fader in any configuration, it flashes through all 210 values until it gets to the color mixing values. so what that looks like like on a 2 second fade in is a bunch of flashing colors (through the early values of color presets and the chases) then it finally makes it to the correct value....


  • MadisonPandaMadisonPanda Registered User
    The only thing I have thought is maybe I could set the "Color" Channel to only use the DMX values from 210-219 so that it wouldnt fade through every DMX value when I use it in a cue list. (on ICFB) fader or any other configuration.

    EL CHEAPO LIghting fixture! ! ! ! ! ! ! channel 1 should not effect everything, its poor planning.
  • Role82Role82 Registered User
    Hi MadisonPanda,

    this one should work. I've commented some lines for better understanding.
    In addition: You created a 5-channel fixture. Each line which says "parameter = xxx" indicates a channel in the fixture. So we have to get rid of the "Macro"-Channel.

    //-------------------------------------------------------
    fixture = CoStrip
    manufacturer = 99
    product = 99
    name = Color Strip
    yoke = no


    output = dmx

    parameter = Colors
    kind = c
    default = 215 // without touching the wheel, you are in ColorMixing-Mode after you patched the fixture
    highlight = 215 // when you use the highlight button on your console, the color should be white (in my opinion), and it's easiest way, is to bring up all color channels to 100% and activate the ColorMixing-Mode
    crossfade = 1 // snaps this channel at the beginning of the fadetime
    type = htp8bit
    range = 85, ColorChange1, noauto // best practice is to use a single value for not changing parameters. Otherwise you can turn the wheel without changing anything to fixture, which can be very annoying ;)
    range = 95, ColorChange2, noauto
    range = 105, ColorChange3, noauto
    range = 115, ColorChange4, noauto
    range = 125, ColorChange5, noauto
    range = 135, ColorChange6, noauto
    range = 145, Chase1, noauto
    range = 155, Chase2, noauto
    range = 165, Chase3, noauto
    range = 175, Chase4, noauto
    range = 185, Chase5, noauto
    range = 195, Chase6, noauto
    range = 205, Chase7, noauto
    range = 215, RGBMix, noauto
    range = 225, ColorFade, noauto

    parameter = Red
    default = 0
    highlight = 255
    crossfade = 0
    type = htp8bit
    range = 0, 255,%

    parameter = Green
    default = 0
    highlight = 255
    crossfade = 0
    type = htp8bit
    range = 0, 255,%

    parameter = Blue
    default = 0
    highlight = 255
    crossfade = 0
    type = htp8bit
    range = 0, 255,%

    If there are still any issues, feel free the ask again.

    Greetings,
    Roman
  • Role82Role82 Registered User
    In this setup the 3 encoders are labeled as follows in the color-section: Colors, Red, Green.
    If you press a second time on the color button, you have access to blue.
    In my opinion it would be better, to move the "Colors" channel to the beam-section to have RGB in one layer in the color-section.
    To archive this, you have to change kind=c to kind=b in the "Colors"-Channel.

    Greetings,
    Roman
  • Role82Role82 Registered User
    If you never want to use, any of the other functions but ColorMixing you can write it like this:

    //-------------------------------------------------------
    fixture = CoStrip
    manufacturer = 99
    product = 99
    name = Color Strip
    yoke = no


    output = dmx

    constant = 215 // this creates a channel, which is always on dmx-value 215. There is no possibility in the console to change this value

    parameter = Red
    default = 0
    highlight = 255
    crossfade = 0
    type = htp8bit
    range = 0, 255,%

    parameter = Green
    default = 0
    highlight = 255
    crossfade = 0
    type = htp8bit
    range = 0, 255,%

    parameter = Blue
    default = 0
    highlight = 255
    crossfade = 0
    type = htp8bit
    range = 0, 255,%
  • MadisonPandaMadisonPanda Registered User
    Hey Roman, Thank you so much for correcting my profile I felt like I was on the right track. This is very helpful!

    So a few questions, what exactly does "crossfade" mean to the hog 500? I know you said it snaps that color channel at the beginning of the fade time. I've done alot of digging into the manual and there is still so much to learn. I will totally try this profile edit and see what we get. And again, thank you so much you are a hero to noob like me!!!
  • Role82Role82 Registered User
    Hi MadisonPanda,

    the crossfade says the console, whether the channel is fadeable through the time section. Let's say you define a fade time of 2secs to a cue, which is the default setting of a clean show in the HOG II OS.

    When you start the cue by pressing on "play" or pull up the fader/press the flash-button (depends on settings), the cue fades in in the desired time. On some channels (e.g. your "Colors"-channel) it makes no sense to fade these channels. So you can define in the fixture profile how these channels behave.

    If in the profile the crossfade is set to 0 (default), it fades in this mentioned time.
    If it's set to 1, it snaps at the beginning of the fade time.
    If it's set to 2, it snaps at the end of the fade time.

    Greetings,
    Roman
  • MadisonPandaMadisonPanda Registered User
    Hey this profile works great now! I knew I was on the right track. You really helped me! Much thanks!!!!! @Role82
Sign In or Register to comment.