Lightconverse - Hog Connectivity Application doesn't launch

LydiaLydia Registered User
Hello everyone!

I’m trying to connect Hog4PC direct to Lightconverse on the same machine without success.

I downloaded the Connectivity Application ( and followed the guide ( direct connection guide.pdf) carefully.

The guide says on the first page: „2. As LIGHTCONVERSE opens, a Wholehog DP dialog box will open at the bottom right of your computer screen and a Hog icon will be placed in the Windows task bar„. But this isn’t the case.

I tried different versions of the Visualizer Connectivity tool, uninstalled it and installed it again. I’m using Windows 8.1.

I think the main problem is, that the previous installed Lightconverse (Net-In Version with dongle, installed months before Hog4PC), doesn’t launch this Connectivity tool. It’s another version of Lightconverse, then the one shipped as accessory to the hog consoles, but it supports HOG-Net (fixtures are patched on HOG-Net).

Does anyone have an idea or any experience with this problem?

Thanks in advance!



  • ivan_mzrivan_mzr Registered User
    I have a similar problem, when the LC open the driver 3.1 open fine but the new one 3.2 dont open i check the task bar and dont see it.
    I re-install the old 3.1 and works then install again the 3.2 and this dont open.

    The process change?
    Im follow the HOG4_HOG_Connectivity_Driver_Guide.pdf manual only change the hog-net to fixture net port.
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff

    Please read this forum post and see if it will provide the answers you need.
  • DNEEdesignsDNEEdesigns Registered User
    I'm having this issue as well.

    I don't believe its a networking issue as i can join the show on my Full Boar 4 Running 3.2. from my HPC running 3.2. The networking is all there and working. The issue i'm having is that the Hog connectivity Driver doesn't launch when i launch LC. I have uninstalled and reinstalled all of the latest downloads and followed all of the guides above with no success.
  • Mike_AMike_A Registered User, Hog Beta, Distributors

    Read the current release notes for 3.2 paying attention to the overhaul of the connectivity to LC. I think this will help you in getting everything playing nice.
  • robrierobrie Registered User

    the connectivity driver doesn't have a pop-up window any more. that is normal.

    if you set the computer running LC and your full boar to DHCP (on the fixturenet port) and have the visualizer stream running from the start menu of the fullboar they should be able to detect each other. it should be that simple.
  • Michael_GrahamMichael_Graham Registered User, Super Moderator, HES Staff

    Are you guys up and running or do you still have questions?
  • nlblightsnlblights Registered User
    I have a hog 3ipc and a full,boar on the way. On the ipc, with the last update done for the 3 series, the connectivity driver will not launch. Even with all networks off, and firewall disabled. Should I just give up and wait to use my full boar on Art-net?
  • MLorenzMLorenz Registered User, Hog Beta
    Does it work with the fullboar when they both have the same settings (IP, net number etc)
    Can you connect to a show that is started on the fullboar and then connect with the ipc to the show?

    Is the correct connectivity driver installed in the matching version?
  • nlblightsnlblights Registered User
    Matching software versions, IPC and full boar can see each other when networked, still no action from the connectivity driver.
  • MLorenzMLorenz Registered User, Hog Beta
    Try to install the matching HOG 3 PC version on your LC-PC.
    And see if HOG PC sees the show. Disable all unused network adaptors on the LC-PC
  • MLorenzMLorenz Registered User, Hog Beta
    Do you have by any chance also an actual version of HOG4 PC installed on the LC-PC?
    Because the whole method has changed after 3.2 of HOG4 OS this will cause confusion...
    Uninstall Hog4 PC and install matching HOG 3 PC version. This will also install the matching connectivity tool
  • nlblightsnlblights Registered User
    I am not using hog 4 at all, just hog 3. Can't get the network connection wizard to launch no matter what I try, including loading hog 3 pc on the light converse computer.
  • MLorenzMLorenz Registered User, Hog Beta
    Disable all unused network adaptors on the LC computer, try to put it th DHCP and let one of the consoles work as a DHCP server
  • nlblightsnlblights Registered User
    Followed and still nothing. Thinking of selling LC and finding a visualizer that will work with Mac. PC's appear to hate me. Lol
  • ScottBScottB Registered User
    Nlblights, I also saw your post over on the LightConverse forums, and sent you and email and got no reply. In any case I'll repost here what I said in case anyone else runs into this issue:
    At the risk of being too late, I stumbled across this post while searching through google for the same problem you're having. I really hope I'm not too late as it is actually a quick and easy fix.

    Seems with the latest LIGHTCONVERSE update it forgot that it was running through hog even when running the HES version of the executable.

    However to fix this, when you patch your fixtures click on DMX Input you'll notice there is a button that says 'Universe' press this and change the universe to a Hog universe. Once you've changed this and hit Apply the WholeHog III visualizer connectivity driver will launch automatically.

    Here is an image album showing you what to look for!
  • ScottBScottB Registered User
    edited March 2016
    edit: double post. please ignore
  • Juay0004Juay0004 Registered User
    Hi everyone,
    I haven been using the visualiser for a while. Had just tried using the visualiser with version 3.3.1 yesterday using the fixture net port as mentioned in the manual.
    It seems that the visualiser take in any HogNet data stream even though the visualiser is detected on the Hog4..
    I swapped the input to ArtNet and it instantaneous work.
    Is LC still suppose to work with HogNet input through the FixtureNet port or it is simply the case where it is just ArtNet after version 3.2?
Sign In or Register to comment.