BUG? Real world values and DMX values

salvadoravilasalvadoravila Registered User
Hi,

I have a custom fixture that keeps doing weird things.

In this fixture I have a parameter that has a DMX values of 0-255 and real world values of 0-777.

When I first built everything worked fine. 100 Real world was 33 DMX.

Now after a restart it seems the real world values are no longer working. When I move past 255 real world the DMX value loops back to 0 and starts again. So when real world is 500 the DMX is 244 then on real world 512 DMX goes back to 0....

Real world limit is still 777 but this equals 9 in DMX

When I open up the fixture in the builder the real world values are still there.. If i change it to say 0-255 then back to 0-777 the console crashes to the background image and needs powercycling.

What am I doing wrong.

Comments

  • MLorenzMLorenz Registered User, Hog Beta
    edited May 2014
    Crashing to Background Image is a Desktopcrash

    press: pig-open-backspace and restart the desktop-process (right-click on it)
  • salvadoravilasalvadoravila Registered User
    edited May 2014
    MLorenz;74454 said:
    Crashing to Background Image is a Desktopcrash

    press: pig-open-backspace and restart the desktop-process (right-click on it)
    Ah great. Thats good to know.

    Thanks!
  • MLorenzMLorenz Registered User, Hog Beta
    edited May 2014
    Which parameter did you use for that channel?

    Because when you only use for example DMX channel as the parameter and real world for that as 0..777 this wont work, because DMX is 255 values per channel.
    Also I would expect that as a normal behaviour because it will make no sense to have for 1 DMX value 3 realworldparameters in row available

    You might try this (means a lot of work, but will work)

    DMX 1 -> real world 1
    DMX 2 -> real world 6
    DMX 3 -> real world 9
    DMX 4 -> real world 12
    ...
Sign In or Register to comment.