HOG 4 Superwidget in a HOG 3 Console

lx@sealx@sea Registered User
I have a HOG 3 console but I want to get a superwidget incase my DP were to fail. Anyone know if the new superwidgets are backward compatible?

Comments

  • ShrunkenNedShrunkenNed Registered User, Hog Beta
    edited March 2014
    Yes, you should be fine.
    The DP's need software loaded depending on if you are using with H3 or H4, but the widgets don't care.
Sign In or Register to comment.