nano drivers help

stagelightstagelight Registered User
HELP I'm trying to find the drivers for my nano. I'm running windows 8, is that the problem ?

Comments

  • MLorenzMLorenz Registered User, Hog Beta
    edited February 2013
    Drivers are installed together with HOG4PC

    Youd need to do an update of ther firmware if you use HOG4PC 1.1.0 or higher builds.
    There is a tech note on the FlyingPig Site how this needs to be done
    http://www.flyingpig.com/support/documents/Nano_Hog_4_Wing_Troubleshoot.pdf

    Then your Nano will be found and installed
  • stagelightstagelight Registered User
    edited February 2013
    I have already done the firmware and driver troubleshoot and have even tried to force a driver load but I get a no driver found message.:confused:
  • dkayserdkayser Registered User, HES Staff
    edited February 2013
    Windows 8 should not be a problem. How does the list in Device Manager look. Is there a Nano Wing listed in Other Devices? Is it listed at all? Are you currently running 1.1.1?

    Donald
  • stagelightstagelight Registered User
    edited February 2013
    I talked to the on call tech and I had to go back 2 versions of software to get it to work. there is a BUG. The computer could not find the drivers. I am running 1.0.1.321 and it is working now.:)
    The nano was listed in devices but had the yellow triangle.
  • dkayserdkayser Registered User, HES Staff
    edited February 2013
    I know there is a bug, I created it. Not purposefully, but one from changing the Nano wing from a single USB device to a composite USB device. This causes earlier versions of driver installers not agree to the interfaces found on newer firmware.

    Here is an alternate method to move from v1.0.1 to v1.1.1. Don't do this unless you have time to work through or downgrade again, I am not in the lab to double-check the procedure, but it should work.

    1. Do the upgrade to 1.1.1 with nano powered off.
    2. Reboot with nano off.
    3. After restarting PC, open Device Manager to confirm no HES widgets.
    4. Hold top-leftmost three buttons (Next Page, Choose 1, Choose 2) on Nano Wing for 3 seconds while powering up Nano Wing. This forces firmware upload before Windows sees any other device and brings firmware up to current version matching installed version. Nano Wing should be listed as a Unloaded Widget for a bit then it should reset and become a Nano Wing again.
    5. This should then get the association correct between new firmware and drivers. Device Manager should now have the Nano Listed as a Highend Widget.

    Donald
  • stagelightstagelight Registered User
    edited February 2013
    I did all that before I called anyone. But it didn't work. The computer saw that it was a nano, it just couldn't find the driver.
  • dkayserdkayser Registered User, HES Staff
    edited February 2013
    Did you have to repeat the procedure to downgrade to 1.0.1?

    Donald
  • stagelightstagelight Registered User
    edited February 2013
    No. the computer recognized it right away.
  • stagelightstagelight Registered User
    edited February 2013
    I just wanted to thank you guys. I didn't expect a response from High End engineers on a Saturday morning. I am up and running with the older version. hopefully I won't have any issues.
    Gino
  • dkayserdkayser Registered User, HES Staff
    edited February 2013
    Then I would conclude that the force firmware upload didn't take when you installed v1.1.1. If the firmware had upgraded, you would have likely had to force it the other way to downgrade. If you want to try again, I would suggest to pay extra attention to the holding of the three buttons and applying power.

    If you are not in a jam and want to try again that would be great for me to see if we can work it out.

    Thanks,
    Donald
  • stagelightstagelight Registered User
    edited February 2013
    I'll give it shot and let you know.
  • stagelightstagelight Registered User
    edited February 2013
    OK. I re-installed 1.0.1.321, rebooted the computer. It showed no wing or widget in the device section. I then held down the three keys and the wing and widget showed up in the device section. Then before I released the keys the nano icon went away. Then I released the keys and the nano icon came back, went away and came back again with the yellow icon.
Sign In or Register to comment.