Road Hog Full Boar Wing Problem

Woodj32177Woodj32177 Registered User
Hey All,
I am having a issue with a Full boar playback wing touchscreen.
For some reason I cannot get the touchscreen to calibrate to the correct screen.
I will calibrate it correctly, but it never controls the correct screen. (Mouse is moving on the laptop display instead of on the roadhog wing screen)

I have talked to Mitch at HES twice, but he seems to think it is a computer problem,
But I am somewhat hesitant to say that is the problem, As I have tried this on 2 different computers with the same effect.

Computers Tried
Lenovo thinkpad, 32bit XP
Macbook Pro, Bootcamp, 32bit XP.

Both have 3.1.7 on a fresh install.
I have installed the correct driver to replace the default USB human interface device...

I have reinstalled HOG 3 PC twice, making sure the ELO touchscreen driver is installed, and being used as the appropriate driver...

I have also tried to make the road hog screen the "Primary" display..

But no matter what I try, the road hog wing touchscreen only works on the laptop display....

Any suggestions would be greatly appreciated...

Joshua Wood

Comments

  • cmuenchowcmuenchow Registered User, Administrator, HES Staff
    edited November 2010
    Have you at any time in the past installed the Elo driver direct from the Elo website? I remember there is some problem related to that driver even when you install our driver over it or after it. There might need to be some uninstallation involved.
  • Woodj32177Woodj32177 Registered User
    edited November 2010
    I don't recall any point there was a elo installation on either computer,
    But i will delete Hog PC, and uninstall the driver, and try it all again....
    Thanks,
    Josh
  • Woodj32177Woodj32177 Registered User
    edited November 2010
    I uninstalled,
    and reinstalled,
    And referenced the driver in the Hog 3 pc directory.
    Same result......

    Any other ideas?
  • quinnquinn Registered User
    edited November 2010
    let's see what your config looks like after a fresh calibration

    use Registry Editor to Export any keys that begin with:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Enum\USB\VID_04E7
  • Woodj32177Woodj32177 Registered User
    edited November 2010
    Here you go,
    I had to change the extension from .reg to .exe to get it to upload, as .reg are not allowed by the forums.

    Let me know if you figure anything out :D
    Joshua Wood
  • quinnquinn Registered User
    edited November 2010
    Woodj32177;50716 said:
    (Mouse is moving on the laptop display instead of on the roadhog wing screen)

    does the cursor travel over the full 1024×768 area of the laptop display, or is it bound to a 800×600 box within the laptop display area?
  • Woodj32177Woodj32177 Registered User
    edited November 2010
    It definitely does not travel the complete distance,
    And could very well be bound to 800x600.

    Also when I swapped the Primary monitor, making the wing the primary,
    I was able to get the touchscreen to be the correct screen, but the only location that was correct was the upper left corner, the rest of the screen would become more off, the farther you got from the upper left corner.

    Joshua Wood
  • quinnquinn Registered User
    edited November 2010
    my apologies, my physical resources are limited and i don't have a machine that has paired to a 2216-based controller from which to pull a known-working config for comparison. perhaps the community at large can provide such a config?


    since i'm stuck on that, i'll share what i can:

    i would agree that your unit is physically functioning; of all the possibilities, your two laptops sharing a trackpad manufacturer is a more likely cause than anything that would require your wing to be RMA'd.

    if running Hog3PC\EloVa.exe starts a calibration sequence, the drivers are installed and working correctly; were they not, you'd instead see "No Elo Touchscreen Found".



    so if: the hardware works, the drivers work, and touching causes any movement (*beep*), the issue's got to be in one of two places:
    the mathematics behind the touchscreen-to-"expanded desktop" coordinate scale transform: the essential variables are stored in what we're calling the config. EloVa might be writing incorrect values to the registry, or elomoufiltr might be reading / applying those values incorrectly. either way, bad math could be a cause, and certainly fits with your "wing as primary, drifts from top-left" finding.

    emitting correctly-calculated mouse instructions: there may be one or more additional and completely unrelated filter drivers in the HID chain, asserting their own control over where the pointer lands; you might see if reverting those trackpad drivers to generics (and restarting) makes any difference.

    i do think it's a config problem, and right now i'm looking specifically at your WindowsMonitorNumber=65538. i'd expect 1 or 2, certainly not 65538 or even -2. but i do notice x/y MonLocn and VirtScrCoord are correct, which leads me to believe that EloVa acquires the correct monitor number and correctly produces MonLocn and VirtScrCoord based off of that correct monitor number, but writes it incorrectly, so when elomoufiltr tries to match touchscreen->monitor->virtual desktop, it fails and defaults to monitor 1. (technically - it looks like the value for the DWORD type, 0x00010000, has ben AND'd to the value for monitor 2, 0x00000002, resulting in WindowsMonitorNumber=0x00010002 instead of WindowsMonitorNumber=0x00000002. see Appendix A-B)


    which Windows monitor number is reported in the Elo control panel > Properties 1? does the Elo "Identify Monitor" button identify the monitor with the same number in the Windows Display control panel?


    if your wing is assigned to be monitor 2, and is arranged to the left of monitor 1, do you see any change in behavior after:[LIST=1]
    [*]calibrating
    [*]using device manager to disable the Elo device
    [*]setting WindowsMonitorNumber = 2
    [*]re-enabling the Elo device
    [/LIST]again, sorry i don't have an actual answer. or a lab full of gear. but i hope you find that something helps.
  • schiefelsschiefels Registered User, HES Alumni
    edited November 2010
    Hi Joshua,

    I just tested and had the exact same problem on my laptop here at the office. I tried all I could think of in Windows to get the touchscreen working properly with the drivers included with Hog3PC but to no avail.

    For right now as a workaround you can:

    1) Uninstall Hog3PC (this will take the Elo drivers with it)
    2) Download the Elo drivers direct from Elo's website: http://www.elotouch.com/Support/Downloads/dnld.asp
    3) Install the drivers and use the Elo Config app to calibrate the touchscreen
    4) Install Hog3PC

    This should get the touchscreen working properly for now. I have logged bug #14507 in regards to this.

    Let me know if that doesn't work for you.

    Thanks,
  • Woodj32177Woodj32177 Registered User
    edited November 2010
    Hey Matt,
    I tried this out,
    And it worked mostly.
    It calibrates correctly. and the "Check Calibration" screen operates correctly.
    But in hog PC it seems incorrect.
    it is correct at the left edge of the screen, but as you get farther away from that portion of the screen, the pointer drifts farther and farther away from the place it is being touched.

    Unfortunately, I have had to pass this off to the road touring technician,
    But i would love to pass along any insights you may have.
    For now, they are just operating without the touchscreen.

    Also, if it helps, Often when this wing is plugged in, it will show up as a unknown wing, and will not operate until you remove it and reinstall it until it shows up correctly.

    Thanks,
    Joshua Wood
Sign In or Register to comment.