Run HOG 3PC as non-administrator

mfs1013mfs1013 Registered User
When I open the HOG 3 on my "limited" account, an error pops up. When I run the HOG 3 on an "administrator" account it procedes to the show selection. How do I make the HOG 3 work on my limited account so i don't have to change my account to admin mode?


  • Joe BleasdaleJoe Bleasdale Registered User
    edited April 2009
    I assume you are running Vista..? If so, take a look at this tech note:

    Taken from the download:
    “Unknown Exception” when running Hog 3PC after installation We recommend turning off Vista " User Access Control" in Windows Control Panel/User Accounts. If you wish to leave UAC on, right click on the Hog 3PC shortcut and select "Run as Administrator".

    I have a feeling that this was what you were seeing. Turn UAC off and things should be OK afterwards. Let us know how you get on.

  • mfs1013mfs1013 Registered User
    edited April 2009
    I run it on XP Pro SP2
  • prmuchaprmucha Registered User
    edited April 2009
    Hmm interesting question. I can't say I've ever tried to access my Hog3 without being an administrator. Check your permissions inside of XP and make sure the program is accessible via all parties. You'll have to basically give administrative rights to all persons with that program only I believe.
  • mfs1013mfs1013 Registered User
    edited April 2009
    I agree
  • quinnquinn Registered User
    edited April 2009
    i notice you've tagged this with group policy, so i'm going to assume you're joined to a domain, which means i have to ask what specifically you mean by "limited" user, and whether or not there are Mandatory Profiles involved.

    any errors prior to the "Wholehog Start" window being shown are most likely to be cause by ACL Deny entries, either on a file system or on the FPS DHCP and TFTP services. Typically, 3PC will not complain and will continue to function, even if it isn't allowed to write to %ProgramFiles%. Though it is of course possible that it's something in your GPO's, such as Software Restriction, or policies concerning the scripting that 3PC uses for some of its configuration.

    either way, it might be helpful to state what the error was, and to post a GPMC-style RSoP logging report against the "limited" user on the target machine. there's always procmon, too.

    for what it's worth, i've found that 3PC is perfectly happy with a standard user token, even when %appdata% is loopback-GPO-redirected to DFS and working offline. so it's definately doable, except for installing hardware.
  • mfs1013mfs1013 Registered User
    edited April 2009
    actually i was hoping that i could change something in my Local Computer Policy, my account is "Limited User"
  • quinnquinn Registered User
    edited May 2009
    i actually ran into this today.

    the "Unknown exception" that occurs immediately after launching launcher is caused by a couple of things, but i'm going to call out specifically a misconfiguration in the 3PC installer, introduced between builds 2071 and 2417.

    the issue is permissions on registry keys; the 3PC installer goes out of its way to remove a standard user's permission to read keys in the registry, via the LockPermissions table (or, rather, a WiX <Permission/>, if i presume correctly)

    when permission to read/traverse these keys is not explicitly removed, UAC registry virtualization facilities are able to kick in and the dhcp and tftp subkeys and their values can be created and modified by any standard user, without launcher throwing on RegCreateKey.

    but this thread asks about XP, which doesn't benefit from UAC.

    so, i'm not sure why, instead of relaxing permissions on the FPS keys so that standard users can write to them, they've been tightened so that standard users cannot even read them...

    of course, i'm also not sure why i hadn't noticed sooner...
Sign In or Register to comment.